Bug 433262 - RTC disabled in recent 2.6.24 builds for fc8 && rawhide
RTC disabled in recent 2.6.24 builds for fc8 && rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 02:49 EST by Marcin Kurek
Modified: 2008-03-06 11:37 EST (History)
0 users

See Also:
Fixed In Version: 2.6.24.3-12.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 11:37:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Kurek 2008-02-18 02:49:22 EST
As I can see recent rawhide kernels (2.6.24) has completly disabled RTC support. 

# CONFIG_GEN_RTC is not set
# CONFIG_RTC_CLASS is not set

I wonder is there any reason to disable RTC completly ? If I remember correctly
PowerMac's doesn't have standard RTC, but some PPC platforms has it (Pegasos for
example) and it would be nice to use it.

Can RTC be enabled in fedora for PPC again ?
Comment 1 Chuck Ebbert 2008-02-20 15:46:50 EST
kernel-2.6.25-ppc.config:
 CONFIG_RTC_CLASS=y
 CONFIG_RTC_DRV_CMOS=y
 CONFIG_RTC_DRV_PPC=y
Comment 2 Marcin Kurek 2008-02-21 17:35:13 EST
What about 2.6.24 fc8 builds ?
Comment 3 Chuck Ebbert 2008-02-21 19:17:38 EST
(In reply to comment #2)
> What about 2.6.24 fc8 builds ?

They are using the exact same configuration as 2.6.23 kernels used.
Comment 4 Marcin Kurek 2008-02-22 08:26:18 EST
I am looking at .config file for 2.6.24.2-10.fc8.ppc (This seems to be latest
koji fc8 2.6.24 kernel) and see:

# CONFIG_GEN_RTC is not set
# CONFIG_RTC_CLASS is not set

Then it seems RTC is also disabled in .24.
Comment 5 Chuck Ebbert 2008-02-22 23:15:42 EST
The GEN_RTC driver got dropped somehow. Fixed in 2.6.24.2-11:

kernel-2.6.24.2-ppc64.config:CONFIG_GEN_RTC=y
kernel-2.6.24.2-ppc64.config:# CONFIG_GEN_RTC_X is not set
kernel-2.6.24.2-ppc64.config:# CONFIG_RTC_CLASS is not set
Comment 6 Fedora Update System 2008-02-27 11:25:02 EST
kernel-2.6.24.3-12.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-02-28 16:44:04 EST
kernel-2.6.24.3-12.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2103
Comment 8 Fedora Update System 2008-03-06 11:37:24 EST
kernel-2.6.24.3-12.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.