Bug 433263 - Slow X11 connections via network
Slow X11 connections via network
Status: CLOSED DUPLICATE of bug 442158
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 02:56 EST by Torsten
Modified: 2008-04-17 04:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 08:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg config-file (594 bytes, application/octet-stream)
2008-02-19 04:46 EST, Torsten
no flags Details
Xorg log for the xorg.conf (50.88 KB, text/plain)
2008-02-19 04:47 EST, Torsten
no flags Details
Xorg log with no xorg.conf (all probed) (54.53 KB, text/plain)
2008-02-19 04:47 EST, Torsten
no flags Details

  None (edit)
Description Torsten 2008-02-18 02:56:22 EST
Description of problem:
When I log-on via a remote X-Server and use graphical applications, some seem to
be very slow 

Steps to Reproduce:
1. Install Fedora-8, accepting all defaults
2. Enable remote XDMCP connections
3. login via an remote X-Server (tried several ones, such as X/Cygwin)
4. Start Eclipse, create project 
5. Re-size (maximise ...) are slow, sometimes 5+ seconds.
6. On the console of the server it is running fine and fast 
7. Set the variable DISPLAY to localhost:0 and the application becomes much slower.
  

Additional info:
During testing we found the 32-bit version of Fedora-8 to work fine. But using
an machine with 16GB RAM we need to use the 64-bit version.

I tried to update all via yum, but this did not help. And using the
alpha-release of Fedora-9 did not help either.

I also tried two different machines, but this did not help.
Comment 1 Matěj Cepl 2008-02-18 10:23:31 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Torsten 2008-02-19 04:46:41 EST
Created attachment 295273 [details]
Xorg config-file
Comment 3 Torsten 2008-02-19 04:47:09 EST
Created attachment 295274 [details]
Xorg log for the xorg.conf
Comment 4 Torsten 2008-02-19 04:47:49 EST
Created attachment 295275 [details]
Xorg log with no xorg.conf (all probed)
Comment 5 Matěj Cepl 2008-02-19 09:25:07 EST
Just to note that there is a large thread on exactly this problem (why is
everybody running eclipse over remote X? Did I miss something?) on fedora-devel
http://thread.gmane.org/gmane.linux.redhat.fedora.devel/73157

The only (unproven and untested, and without any response in the thread)
suggestions were:

a) make sure that nothing looking directly or indirectly like 127.0.0.1 is involved 
b) use freenx (the results on this are rather mixed)

However, passing to the developers to see whether they have any idea about this.
Comment 6 Torsten 2008-02-20 03:31:16 EST
I would not say you missed something, but X is a network protocol. You can (and
should) use remote X. So we have got our Fedora box on a server-hardware, log-in
with some ten users and develop software. Of course using Eclipse as well. Apart
from the X problem it is running fine so far and helps to share resources.
Comment 7 Adam Jackson 2008-02-21 11:00:16 EST
X's network layer hasn't changed materially, so I'm inclined to blame network
performance problems on the application.
Comment 8 Andrew Overholt 2008-02-21 11:08:31 EST
This definitely isn't a CDT issue.  I guess one could try an older Eclipse
release and see if the problem persists.  I don't know what changed with SWT's
drawing or whatever so that'll require some investigation, I guess.

Torsten:  does this happen with upstream downloads of eclipse as well?  If so,
we should really file this there.
Comment 9 Torsten 2008-02-22 02:59:25 EST
Well to be honest using Eclipse 3.2 it works fine, but 3.3 is slow. 

Nevertheless we have to some other home-made java apps (sing) that are *very*
slow, too. And the overall impression is: The 64-bit system displays graphics
noticably slower than the 32-bit. So I am a bit stuck to say who is guilty.
Maybe X, gtk, java or whatever.
Comment 10 Andrew Overholt 2008-02-22 09:06:18 EST
Okay, let's try to isolate some variables.  Try the following:

upstream eclipse 3.2 on F8 with IcedTea
upstream eclipse 3.3 on F8 with IcedTea

Is 3.3 slower than 3.2?  If so, it looks like an upstream issue.

upstream eclipse 3.2 on F8 with IcedTea
upstream eclipse 3.2 on F8 with the Sun JVM

Is it slower with IcedTea?

upstream eclipse 3.2 on F7 with the Sun JVM
upstream eclipse 3.2 on F8 with the Sun JVM

Is it slower on F8?

upstream eclipse 3.3 on F8 with IcedTea
Fedora eclipse on F8 with IcedTea

Is Fedora Eclipse slower?  If so, it looks like some (I don't know how) issue in
Fedora Eclipse.
Comment 11 Torsten 2008-03-12 09:58:57 EDT
Hello again ... sorry for the delay, but I needed to do some other work first.
The simple answer to all your questions is:

* Eclipse 3.2 is much faster than 3.3
* I cannot see a difference between Eclipse (from Eclipse.org) and Fedora-Eclipse
* I cannot see a difference with different VMs (IcedTea, Sun, 32-bit, 64-bit)
* Eclipse on F7 seems faster than on F8
* Eclipse on F8-32bit seems faster than on F8-64bit.
Comment 12 Andrew Overholt 2008-03-12 10:46:52 EDT
(In reply to comment #11)
> Hello again ... sorry for the delay, but I needed to do some other work first.

No problem.  Thanks for testing!

> * Eclipse 3.2 is much faster than 3.3

Okay.

> * I cannot see a difference between Eclipse (from Eclipse.org) and Fedora-Eclipse

Good.

> * I cannot see a difference with different VMs (IcedTea, Sun, 32-bit, 64-bit)

Good.

> * Eclipse on F7 seems faster than on F8

F7 had 3.2.x and F8 has 3.3.x.

> * Eclipse on F8-32bit seems faster than on F8-64bit.

Odd.

I think at this point we need to move this upstream, since it looks like
something changed in SWT (Eclipse's widget toolkit) or SWT's gtk interaction. 
If you're sure that 3.2.x is noticeably faster on F8 than 3.3.x is (upstream
downloads in all cases), file a bug at bugs.eclipse.org against Platform->SWT
and CC me, please.  When you've filed it, mark this as upstream and put a
reference to the bug here.  Thanks, Torsten!
Comment 13 Torsten 2008-03-17 08:09:12 EDT
There are several bug-entries @eclipse, so one is here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=104271
Comment 14 Torsten 2008-04-17 04:38:53 EDT
Ah, after some more debugging I found the real problem. This is already
described in:

https://bugzilla.redhat.com/show_bug.cgi?id=442158

So I am closing this as a dublicated of the bug above, 

*** This bug has been marked as a duplicate of 442158 ***

Note You need to log in before you can comment on or make changes to this bug.