Bug 433264 - KDE3's widget styles are not applying
KDE3's widget styles are not applying
Status: CLOSED DUPLICATE of bug 433235
Product: Fedora
Classification: Fedora
Component: kdelibs3 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: KDE4Live
  Show dependency treegraph
 
Reported: 2008-02-18 03:30 EST by Sebastian Vahl
Modified: 2008-02-18 06:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 06:35:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
using default widget style with a clean $HOME/.kde (182.35 KB, image/png)
2008-02-18 04:01 EST, Sebastian Vahl
no flags Details
using polyester (192.09 KB, image/png)
2008-02-18 04:02 EST, Sebastian Vahl
no flags Details
using polyester with a modified $HOME/.kde/share/config/kdeglobals (193.35 KB, image/png)
2008-02-18 04:04 EST, Sebastian Vahl
no flags Details

  None (edit)
Description Sebastian Vahl 2008-02-18 03:30:12 EST
Description of problem:
It's not possible to change the widget styles for KDE3 applications anymore. 
In the past it was possible to use eg. polyester for KDE4 apps and polyester3 
for KDE3 apps. Now the KDE3 applications use a style that looks like the 
old "B2".


Version-Release number of selected component (if applicable):
kdelibs3-3.5.9-2.fc9.i386
kdebase3-3.5.9-1.fc9.i386
kdelibs-4.0.1-3.fc9.i386
kdebase-runtime-4.0.1-1.fc9.i386
kdebase-workspace-4.0.1-7.fc9.i386
kdebase-4.0.1-3.fc9.i386

How reproducible:
ever

Steps to Reproduce:
1. Login into a clean user account
2. start a KDE3 application. The style would be "B2" (not Plastik)
or
1. yum install polyester polyester3
2. change style in systemsettings to polyester
3. start a KDE3 application. The style would be "B2" (not polyester)
  
Actual results:
KDE3 widget style seems to be B2

Expected results:
KDE3 widget style should be Plastik as default. And if there is a matching 
theme for KDE3 and KDE4 it should be using this theme also in KDE3 
applications.

Additional info:
Maybe kdelibs3 isn't the right component for this bug.
Comment 1 Kevin Kofler 2008-02-18 03:37:32 EST
Normally, the logic is supposed to be:
* if widgetStyle4 is set in kdeglobals (something I added to allow different 
themes in KDE 3 and 4, but systemsettings doesn't use it at the moment), KDE 3 
uses widgetStyle, KDE 4 uses widgetStyle4
* if widgetStyle4 is not set, KDE 4 also uses widgetStyle, like KDE 3

So setting the style to Polyester is supposed to set it for both KDE 3 and 4.
Comment 2 Sebastian Vahl 2008-02-18 04:00:54 EST
(In reply to comment #1)
> So setting the style to Polyester is supposed to set it for both KDE 3 and 
4.

This was working before (eg. on Fedora-9-Alpha). But now it seems to not work 
anymore. 

I attach some screenshots so that you could have a look at yourself.
1. using a clean $HOME/.kde (should be KDE4: oxygen, KDE3: plastik)
2. using polyester (in KDE4 and KDE3)
3. using a modified $HOME/.kde/share/config/kdeglobals with polester

I've done a re-login after applying the changed style to get sure that the 
KDE3 apps are catching this up.
Comment 3 Sebastian Vahl 2008-02-18 04:01:28 EST
Created attachment 295144 [details]
using default widget style with a clean $HOME/.kde
Comment 4 Sebastian Vahl 2008-02-18 04:02:23 EST
Created attachment 295145 [details]
using polyester
Comment 5 Sebastian Vahl 2008-02-18 04:04:00 EST
Created attachment 295146 [details]
using polyester with a modified $HOME/.kde/share/config/kdeglobals

I've manually insterted this into $HOME/.kde/share/config/kdeglobals:
widgetStyle=polyester
widgetStyle3=polyester
widgetStyle4=polyester
Comment 6 Kevin Kofler 2008-02-18 04:09:39 EST
Hmmm, could this be caused by this change to kdelibs3?
* Mon Feb 11 2008 Than Ngo <than redhat com> 3.5.8-24
- make kresources hidden on f9+
Comment 7 Kevin Kofler 2008-02-18 04:11:38 EST
Looking at it, I doubt that's it though. But I don't know what's the source of 
breakage there. (By the way, widgetStyle3 is not used anywhere.)
Comment 8 Kevin Kofler 2008-02-18 04:13:29 EST
Hmmm, if you remove the KDE 4 Polyester, does KDE 3 then load the KDE 3 one? I 
suspect KDE 3 may be trying to load the KDE 4 style, which obviously fails.
Comment 9 Sebastian Vahl 2008-02-18 04:24:37 EST
(In reply to comment #8)
> Hmmm, if you remove the KDE 4 Polyester, does KDE 3 then load the KDE 3 one? 
I 
> suspect KDE 3 may be trying to load the KDE 4 style, which obviously fails.

No. It's still not working. I've also downgraded to 
kdelibs3-3.5.8-22.fc9.i386.rpm (the version used on Fedora-9-Alpha) and 
removed $HOME/.kde. It's still using the (look as) B2-Theme.

Comment 10 Kevin Kofler 2008-02-18 05:41:27 EST
Hmm, I think I know what's wrong. Are you using qt-3.3.8b-4.fc9? If so, please 
downgrade to qt-3.3.8b-3.fc9 until Than commits my fix for bug 433235, that 
should fix it. (If you're indeed using that broken qt, we can mark this as a 
duplicate of bug 433235.)
Comment 11 Kevin Kofler 2008-02-18 05:42:19 EST
Actually, Than just gave me commit access to qt, so I can commit it myself. :-)
Comment 12 Sebastian Vahl 2008-02-18 06:35:54 EST
(In reply to comment #10)
> Hmm, I think I know what's wrong. Are you using qt-3.3.8b-4.fc9? If so, 
please 
> downgrade to qt-3.3.8b-3.fc9 until Than commits my fix for bug 433235, that 
> should fix it.

That was the problem. After downgrading to qt-3.3.8b-3.fc9 the default widget 
style is Plastik again and also the switch to polester/polyester3 is working 
again.

(In reply to comment #10)
> (If you're indeed using that broken qt, we can mark this as a 
> duplicate of bug 433235.)

Done

*** This bug has been marked as a duplicate of 433235 ***

Note You need to log in before you can comment on or make changes to this bug.