Bug 433338 - GLibC 2.5-18.el5_1.1 fails self-test on "check-localpl"
GLibC 2.5-18.el5_1.1 fails self-test on "check-localpl"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc (Show other bugs)
5.1
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 14:12 EST by Steve Snyder
Modified: 2008-02-19 11:13 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 11:13:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2008-02-18 14:12:18 EST
Description of problem:

Build of GLibC fails self-test.

Version-Release number of selected component (if applicable):

2.5-18.el5_1.1

How reproducible:

Didn't try

Steps to Reproduce:
1. rpm -ivh glibc-2.5-18.el5_1.1.src.rpm
2. rpmbuild -bi --target i686 SPECS/glibc.spec
3.
  
Actual results:

Test "check-localpl" fails self-test ("make check" in spec file)

Expected results:

An unmodified source RPM should not have build failures.

Additional info:

Seen on a fully-updated RHEL 5.1 system.

From file BUILD/glibc-2.5-20061008T1257/build-i686-linuxnptl/check.log:


/home/rpmbuild/rpmbuild/BUILD/glibc-2.5-20061008T1257/build-i686-linuxnptl/elf/tst-tls9-static.o:
In function `do_test':
/home/rpmbuild/rpmbuild/BUILD/glibc-2.5-20061008T1257/elf/tst-tls9.c:17:
warning: Using 'dlopen' in statically linked applications requires at runtime
the shared libraries from the glibc version used for linking
make[2]: ***
[/home/rpmbuild/rpmbuild/BUILD/glibc-2.5-20061008T1257/build-i686-linuxnptl/elf/check-localplt.out]
Error 1
make[2]: Target `tests' not remade because of errors.
make[2]: Leaving directory
`/home/rpmbuild/rpmbuild/BUILD/glibc-2.5-20061008T1257/elf'
make[1]: *** [elf/tests] Error 2
.
.
.
make[1]: Target `check' not remade because of errors.
make[1]: Leaving directory `/home/rpmbuild/rpmbuild/BUILD/glibc-2.5-20061008T1257'
make: *** [check] Error 2

Contents of file
BUILD/glibc-2.5-20061008T1257/build-i686-linuxnptl/elf/check-localplt.out:

--- ../scripts/data/localplt-i386-linux-gnu.data        2006-01-11
16:06:19.000000000 -0500
+++ -   2008-02-18 13:31:47.061233553 -0500
@@ -2,6 +2,5 @@
 libc.so: calloc
 libc.so: free
 libc.so: malloc
-libc.so: memalign
 libc.so: realloc
 libm.so: matherr
Comment 1 Jakub Jelinek 2008-02-19 11:13:11 EST
That's expected, due to malloc/ changes on redhat branch.   Not a bug of any kind.

Note You need to log in before you can comment on or make changes to this bug.