Bug 433375 - need to clean up directory /usr/lib/xulrunner-1.90re/dictionaries before trying to replace it with a symbolic link
need to clean up directory /usr/lib/xulrunner-1.90re/dictionaries before tryi...
Status: CLOSED DUPLICATE of bug 433096
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 16:55 EST by Jonathan Kamens
Modified: 2008-02-18 17:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 17:41:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-02-18 16:55:17 EST
Can't install current xulrunnner from rawhide:

Error unpacking rpm package xulrunner-1.9-0.beta3.22.nightly20080215.fc9.i386
error: failed to stat /home/jik/.gvfs: Permission denied
error: unpacking of archive failed on file
/usr/lib/xulrunner-1.9pre/dictionaries: cpio: rename

This is because /usr/lib/xulrunner-1.9pre/dictionaries already exists as a
directory, and the new RPM wants it to be a symbolic link.

Don't know whether this is a yum but or an xulrunner RPM bug.  Suspect it's
probably the responsibility of the RPM to have a %pre script to clean up in
situations like this.
Comment 1 Matěj Cepl 2008-02-18 17:41:18 EST

*** This bug has been marked as a duplicate of 433096 ***

Note You need to log in before you can comment on or make changes to this bug.