This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 433399 - kate appears in Applications -> Other
kate appears in Applications -> Other
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-02-18 20:41 EST by Jens Petersen
Modified: 2008-02-27 10:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 10:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-02-18 20:41:25 EST
Description of problem:
Kate appears in the main desktop Applications menu under Other applications.

Version-Release number of selected component (if applicable):
kdesdk-4.0.1-1.fc9

How reproducible:
every time

Steps to Reproduce:
1. yum install kdesdk
  
Actual results:
1. appears at Applications -> Other -> Kate 

kate.desktop has "Categories=Qt;KDE;TextEditor;"

Expected results:
2. Kate should appear under Programming or Accessories
Comment 1 Kevin Kofler 2008-02-18 20:54:44 EST
According to http://standards.freedesktop.org/menu-spec/latest/apa.html , the 
TextEditor category should always used in conjunction with the Utility 
category. We need to test if adding the Utility category doesn't break the KDE 
menu though. (Currently Kate is listed under "Utilities/Editors" where it 
belongs, we don't want it duped under the top-level "Utilities" menu.)
Comment 2 Jens Petersen 2008-02-18 22:24:32 EST
Hmm, so is this a GNOME bug then?
Comment 3 Kevin Kofler 2008-02-18 22:28:06 EST
The spec says kate.desktop should define a primary category (such as Utility) 
in addition to TextEditor (which is an additional category), but of course it 
would also be possible to change redhat-menus to do something useful with the 
TextEditor category.
Comment 4 Rex Dieter 2008-02-27 10:22:30 EST
added Category=Utility

* Wed Feb 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-2
- kate appears in Applications -> Other (#433399)

Note You need to log in before you can comment on or make changes to this bug.