Bug 433413 - Stopping the kerneloops service fails during system shutdown
Stopping the kerneloops service fails during system shutdown
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kerneloops (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 00:11 EST by Ray Todd Stevens
Modified: 2011-12-13 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-13 10:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-02-19 00:11:00 EST
I get a failure without any other messages on shutdown or reboot from this
system.   My boot.log contains no data so I am not sure where else to look for
information.

The configuration is as installed from a fresh install
Comment 1 Ray Todd Stevens 2008-02-25 23:03:21 EST
kernelopps still failing with latest updates.
Comment 2 Ray Todd Stevens 2008-02-26 23:13:39 EST
I decided to look at some debugging.    So I decided to run the init script and
do a reload.   The unload and reload seem to work.   I wonder if the problem is
this scripts place in the list.

Should this be transfered to the init scripts group ?
Comment 3 Chuck Ebbert 2008-02-29 16:42:25 EST
Looks like kerneloops has already died by the time the initscript tries to kill it.
Comment 4 Ray Todd Stevens 2008-03-01 09:06:36 EST
Any way that I can help confirm this.   On the other hand it does sound like you
are already able to make this happen for you?
Comment 5 Chuck Ebbert 2008-03-04 15:02:28 EST
K73messagebus is killing it. Looks like it needs to require $syslog during
shutdown...
Comment 6 Ray Todd Stevens 2008-03-04 15:44:13 EST
so do we need to make it like 72 instead of 90.   I could try this and see i
anything breaks if this would help.
Comment 7 Chuck Ebbert 2008-03-04 17:53:48 EST
Should be fixed in 0.10-6
Comment 8 Christopher Stone 2008-05-25 11:33:44 EDT
Hi, I still get this problem using kerneloops-0.10-11.fc9.x86_64.  I did a yum
install kerneloops, then enabled and started the service using
system-config-services.  In rc6.d/ I have:
lrwxrwxrwx 1 root root 20 2008-05-25 08:18 K74kerneloops -> ../init.d/kerneloops
lrwxrwxrwx 1 root root 20 2007-03-25 07:41 K74lm_sensors -> ../init.d/lm_sensors
lrwxrwxrwx 1 root root 14 2008-05-13 15:56 K74nscd -> ../init.d/nscd
lrwxrwxrwx 1 root root 17 2008-05-13 16:14 K74rsyslog -> ../init.d/rsyslog

I don't know why it isn't working.  Can you maybe try making the kill number
lower or something?
Comment 9 Chuck Ebbert 2008-06-17 14:56:22 EDT
It should be 73 after the update:

K73auditd -> ../init.d/auditd
K73kerneloops -> ../init.d/kerneloops
K73messagebus -> ../init.d/messagebus
K73winbind -> ../init.d/winbind
K73ypbind -> ../init.d/ypbind
Comment 10 Ray Todd Stevens 2008-08-09 20:55:52 EDT
I believe that this one is fixed.   Shouldn't we close it?
Comment 11 Christopher Stone 2008-08-10 11:37:38 EDT
Seems to be working for me now now, thanks.

Note You need to log in before you can comment on or make changes to this bug.