Bug 433439 - Broken dependency
Summary: Broken dependency
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: granule (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Vladislav Grinchenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-19 10:31 UTC by Michael Schwendt
Modified: 2008-11-08 16:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 16:08:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2008-02-19 10:31:41 UTC
source rpm: granule-1.2.4-2.fc7.src.rpm
package: granule - 1.2.4-2.fc7.i386 from fedora-8-i386
  unresolved deps: 
     libassa-3.4.so.0

Why has libassa not been pushed to testing first?

Comment 1 Vladislav Grinchenko 2008-02-19 17:01:50 UTC
My bad. I misread the instructsions. The newly released libassa-3.5.0 should
have been deployed not as an update to libassa-3.4.0, but rather as a separate
package since they can be installed in parallel. 

My intention was to upgrade granule-1.2.4 to granule-1.3.0 which requires
libassa-3.5.0.

Should I just remove granule-1.2.4 from fc8?

best,
--Vlad

Comment 2 Michael Schwendt 2008-02-20 00:30:14 UTC
I don't understand your plans. Why remove anything if you want
to upgrade it anyway?

In a case like this, simply upgrade both libassa and granule
_at once_. You can tell bodhi, the Fedora Updates System, to
push a _set_ of packages.

[...]

In general, if a library is API- or ABI-incompatible (as in the
case of the new libassa) and has not been released into the
Fedora repositories yet, mail releng and request that the build
in koji is tagged into the buildroot and made available for
subsequent build jobs. Then you can build any dependencies
and push all results at once in a good set that doesn't break.

Since the new libassa is in the updates repository already, you
don't need to mail releng this time.


Comment 3 Vladislav Grinchenko 2008-02-20 04:59:56 UTC
I wasn't aware that you can push a _set_ of packages. Thanks for the tip.

"... mail releng and request that the build
in koji is tagged into the buildroot and made available for
subsequent build jobs." 

I guess I missed 'releng' feature alltogether - it must have been described
somewhere. 

thanks for your advise. 

Comment 4 Russell Harrison 2008-02-22 16:13:53 UTC
I can confirm that updating granule from the updates-testing repo works as
expected.  Is it ready to be pushed to the updates repo?

$ sudo yum --enablerepo=updates-testing update granule
...
Updated: granule.i386 0:1.3.0-0.fc8 libassa.i386 0:3.5.0-1.fc8
Complete!


Comment 5 Vladislav Grinchenko 2008-02-22 18:51:17 UTC
Yes, it is. 

I have done a fair amount of testing myself both on FC-7 and FC-8 systems and
everything seems to be in place and working.



Comment 6 Yaakov Nemoy 2008-03-12 15:37:47 UTC
Is this still a bug?

If not, can we close it?

Comment 7 Michael Schwendt 2008-03-12 16:15:29 UTC
Yes, the granule update does not show up in the broken deps.
But that is something you can verify easily yourself.


Note You need to log in before you can comment on or make changes to this bug.