Bug 433444 - php update create a dependancie issue with raydium & maniadrive
php update create a dependancie issue with raydium & maniadrive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: maniadrive (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
: 452936 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 06:18 EST by Th0ma7
Modified: 2008-06-30 00:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.2-9.fc8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-28 18:16:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Th0ma7 2008-02-19 06:18:08 EST
Description of problem:
While trying to apply the latest php update on fedora 8
Missing Dependency: libphp5-5.2.4.so()(64bit) is needed by package raydium
Missing Dependency: libphp5-5.2.4.so()(64bit) is needed by package maniadrive
Missing Dependency: libphp5-5.2.4.so()(64bit) is needed by package
maniadrive-track-editor

I think it might be usefull for them to be linked directly to libphp5.so instead?
Comment 1 Kevin DeKorte 2008-06-22 09:56:59 EDT
happens on 32bit as well.
Comment 2 Zoltan Boszormenyi 2008-06-23 05:11:16 EDT
And on Fedora 9 as well. Uninstalled maniadrive before updating php and
now it cannot be installed again because of this dependency.
Comment 3 Samuel Sieb 2008-06-25 13:20:08 EDT
The packages have been rebuilt but haven't been pushed yet for some reason.

You can download them from:
http://koji.fedoraproject.org/koji/buildinfo?buildID=53422
Comment 4 Samuel Sieb 2008-06-25 13:24:15 EDT
Sorry, I just realized that is only for F9.  They haven't been built for F8.
Comment 5 Hans de Goede 2008-06-25 13:36:47 EDT
Changing component to maniadrive, as that is to blame.

My bad, I didn't think about checking if this php update hit F-8 too while
fixing F-9. A fix is on its way now.
Comment 6 Fedora Update System 2008-06-25 13:55:23 EDT
maniadrive-1.2-9.fc8 has been submitted as an update for Fedora 8
Comment 7 Hans de Goede 2008-06-26 02:50:29 EDT
*** Bug 452936 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-06-26 04:34:15 EDT
maniadrive-1.2-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Douglas Wooster 2008-06-27 00:54:58 EDT
Thanks for the prompt push, but the updated maniadrive and raydium call for 
libphp5-5.2.5.so while the current level of php-embedded is 5.2.6-2.fc8, so now 
get

Error: Missing Dependency: libphp5-5.2.5.so is needed by package maniadrive
Error: Missing Dependency: libphp5-5.2.5.so is needed by package raydium
Comment 10 Douglas Wooster 2008-06-27 00:56:46 EDT
Argh, Bugzilla won't let me reopen this bug, so I'm also posting 452936, which 
it does allow me to reopen.
Comment 11 Hans de Goede 2008-06-27 02:54:53 EDT
Reopening.

Thanks very much for reporting this, I don't understand how this has happened,
quoting from the changelog for the next update:

* Sat Jun 21 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.2-9.fc8.1
- Rebuild again for new php version, for some reason the old php was still
  in the buildroot even though the new one was in updates-stable for some
  time when the build was started. Force getting the new version by using
  a versioned BuildRequires

So now we should either get the right php, or a failed build. I will double
check this before pushing the next version as an update.
Comment 12 Hans de Goede 2008-06-27 02:55:40 EDT
*** Bug 452936 has been marked as a duplicate of this bug. ***
Comment 13 Hans de Goede 2008-06-27 03:03:03 EDT
Hmm, good I added the version check, the build now failed:

DEBUG util.py:250:  No Package Found for php-devel >= 5.2.6

So for some strange reason php-5.2.6 is not making its way into the buildroot.
Comment 14 Fedora Update System 2008-06-27 17:13:48 EDT
maniadrive-1.2-9.fc8.1 has been submitted as an update for Fedora 8
Comment 15 Hans de Goede 2008-06-27 17:15:34 EDT
Ok, the right php is now in the buildroot and a new build has been done, so the
next update should really fix this.
Comment 16 Douglas Wooster 2008-06-27 21:42:37 EDT
OK, thank you.  I'll be watching for it.
Comment 17 Fedora Update System 2008-06-28 18:15:57 EDT
maniadrive-1.2-9.fc8.1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Douglas Wooster 2008-06-30 00:34:41 EDT
OK, this resolves the problem.
maniadrive and raydium 1.2-9.fc8.1 install with php 5.2.6-2.fc8
Thank you.

Note You need to log in before you can comment on or make changes to this bug.