Bug 433463 - latest rawhide update breaks encrypted volumes
latest rawhide update breaks encrypted volumes
Status: CLOSED DUPLICATE of bug 432813
Product: Fedora
Classification: Fedora
Component: cryptsetup (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 09:12 EST by Ray Todd Stevens
Modified: 2014-03-16 23:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 17:00:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (1.20 MB, image/jpeg)
2008-02-19 16:58 EST, Ray Todd Stevens
no flags Details

  None (edit)
Description Ray Todd Stevens 2008-02-19 09:12:00 EST
Description of problem:

Ran an update last night.    Now when I get the prompt for the passwphrase, it
tells me that there are no volumes with a matching key and the boot obvously
fails.   Not good.
Comment 1 Ray Todd Stevens 2008-02-19 12:02:30 EST
I do assume you need more information, and so I have left the machine alone so I
can try and test anything you need me to.   Tell me what to do and I will get
you more information than my limited description.

Comment 2 Will Woods 2008-02-19 13:52:12 EST
This is probably a duplicate of bug 432813.

Do you see messages like these?

Failed to setup dm-crypt key mapping. 
Check kernel for support for the aes-cbc-essiv:sha256 cipher spec and verify
that /dev/sda2 contains at least 133 sectors.

Comment 3 Ray Todd Stevens 2008-02-19 16:49:26 EST
The screen then zips up really fast.  Way to fast to even think about reading
it.   Then the top line which is past the old bottom line is

command failed no key available with this pass phrase.

I don't see any way to read the messages before this.
Comment 4 Ray Todd Stevens 2008-02-19 16:58:03 EST
Created attachment 295345 [details]
screen shot

I managed to get a screen shot with my camera.	This sure took a lot of tries.
Comment 5 Will Woods 2008-02-19 16:59:41 EST
Shift-PageUp/PageDown should let you scroll back on the console.
Comment 6 Will Woods 2008-02-19 17:00:46 EST
Aaand, yes, there's the aes-cbc-essiv:sha256 message. Same as 432813 then.

*** This bug has been marked as a duplicate of 432813 ***

Note You need to log in before you can comment on or make changes to this bug.