Bug 433473 - pulse cannot bind to port 539 after a restart, child processes still have it open
pulse cannot bind to port 539 after a restart, child processes still have it ...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: piranha (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On: 391131
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 10:22 EST by Marek Grac
Modified: 2009-04-16 16:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0794
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2008-02-19 10:22:58 EST
+++ This bug was initially created as a clone of Bug #391131 +++

Description of problem: In the failover server (fos) configuration, the daemon
pulse leaves open a file descriptor for port 539 when it forks sub-processes. 

This includes ALL user specified programs started in /etc/sysconfig/ha/lvs.cf
using the 'start_cmd' directive.

Unless ALL programs terminate (including user specified ones), the next time you
start pulse on the same host, it will fail because it can't bind to the port.
All child processes of the first pulse are bound to the port, making it
unavailable to the new pulse.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Configure /etc/sysconfig/ha/lvs.cf to have start_cmd call a program that
never ends (ie "while [ 1 ]; do sleep 10 ; done ; ")
2. /etc/init.d/pulse stop # fails over second node
3. /etc/init.d/pulse start
  
Actual results:


Expected results:


Additional info:

While fos, nanny, and pulse may need port 539 open, pulse should close the
descriptor before it calls "start_cmd".

-- Additional comment from nstraz@redhat.com on 2007-12-13 12:30 EST --
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.
Comment 1 RHEL Product and Program Management 2008-03-31 10:07:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 errata-xmlrpc 2008-07-25 15:08:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0794.html

Note You need to log in before you can comment on or make changes to this bug.