Bug 433479 - vgsplit may fail to delete old VG dev entries
vgsplit may fail to delete old VG dev entries
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.5
All Linux
low Severity low
: rc
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 10:50 EST by Corey Marthaler
Modified: 2008-06-04 16:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 16:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-02-19 10:50:57 EST
Description of problem:
One of our regression tests is to vgsplit out pvs to a new vg and then split it
back to the orginal vg. Sometimes we need up spliting out all the pvs in the vg
so it becomes more of a rename operation. In this case it failed to split back
because the device entry from the first vg was not deleted.

[lvm_single_config] VOLUME SPLIT of in use pvs from stripe_5_3474 to split_359
on hayes-01
[lvm_single_config] deactivating volume group
[lvm_single_config] checking that new vg split_359 exists on hayes-01
[lvm_single_config]
[lvm_single_config] VOLUME SPLIT split_359 back into stripe_5_3474 on hayes-01
[lvm_single_config]   /dev/stripe_5_3474: already exists in filesystem
[lvm_single_config]   New volume group name "stripe_5_3474" is invalid
[lvm_single_config] vgsplit failed:


[root@hayes-01 ~]# ls -lrt /dev/stripe_5_3474/
total 0
lrwxrwxrwx  1 root root 31 Feb 18 19:34 snap1 -> /dev/mapper/stripe_5_3474-snap1
lrwxrwxrwx  1 root root 31 Feb 18 19:34 snap0 -> /dev/mapper/stripe_5_3474-snap0

However, it I choose a different vg name to split to, the operation works.

Here are the lvs currently in the vg:
  snap0          split_359  swi--- 100.00M stripe_5_34740                      
 /dev/etherd/e1.1p6(0)                              
  snap1          split_359  swi---  48.00M stripe_5_34740                      
 /dev/etherd/e1.1p6(25)                             
  stripe_5_34740 split_359  owi---   7.39T                                     
 /dev/etherd/e1.1p1(0),/dev/etherd/e1.1p2(0),/dev/etherd/e1.1p3(0),/dev/etherd/e1.1p4(0),/dev/etherd/e1.1p5(0)


Version-Release number of selected component (if applicable):
2.6.9-55.0.16.ELsmp
lvm2-2.02.21-5.el4
device-mapper-1.02.17-3.0.1.el4
Comment 1 Dave Wysochanski 2008-02-20 12:24:32 EST
Corey can you show me how to run this test or give me the cmdlines that I can
repro myself?

Thanks.
Comment 2 Dave Wysochanski 2008-02-20 12:24:52 EST
Also, I assume this is a regression from the previous release?
Comment 3 Corey Marthaler 2008-06-04 16:46:36 EDT
I was unable to reproduce this bug in the lastest 4.7 rpms, closing.

2.6.9-70.ELsmp
lvm2-2.02.36-1.el4

Note You need to log in before you can comment on or make changes to this bug.