Bug 433520 - Latest driver won't light the VGA display on a Radeon X300SE
Latest driver won't light the VGA display on a Radeon X300SE
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 15:07 EST by Chris Siebenmann
Modified: 2009-01-09 02:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:40:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xrandr -q output (698 bytes, text/plain)
2008-02-19 15:08 EST, Chris Siebenmann
no flags Details
Xorg.0.log-working (72.68 KB, text/plain)
2008-02-19 15:09 EST, Chris Siebenmann
no flags Details
Xorg.0.log-broken (127.68 KB, text/plain)
2008-02-19 15:11 EST, Chris Siebenmann
no flags Details
Xorg Log from 6.7.197 (VGA head doesn't come on) (772.31 KB, text/plain)
2008-02-23 12:11 EST, Ray Van Dolson
no flags Details
Xorg Log from 6.8.0 (VGA head comes on) (100.50 KB, text/plain)
2008-02-23 12:11 EST, Ray Van Dolson
no flags Details

  None (edit)
Description Chris Siebenmann 2008-02-19 15:07:31 EST
Description of problem:

I have an ATI Radeon X300SE card (identified by lspci as an 'RV370 5B60')
connected to two LCD panels, one by VGA and one by DVI. When I install
the latest xorg-x11-drv-ati update, the radeon driver no longer lights
up the VGA panel when it starts; instead the panel drops into power down
sleep mode. This happens with both my usual xorg.conf and with no xorg.conf.

When I run with my usual xorg.conf (which preconfigures the panels and
uses EXA acceleration), the DVI panel also comes up with very slow
graphics updates when doing things like scrolling text in xterm. Turning
off the VGA panel in xrandr fixes this (and also relocates what the
DVI panel is displaying).

Using xrandr to turn off then VGA output and then turn it back on makes
no difference.

This worked with driver versions as recent as xorg-x11-drv-ati-6.7.196-2.fc8
and as old as the xorg-x11-drv-ati version on the install CD (which I had to
fall back to because it is the only other version still available online).

The output of 'xrandr -q' is identical between a working and a non-working
configuration; I will attach it and the Xorg.0.log files for both cases to
this bug report.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.7.197-1.fc8
Comment 1 Chris Siebenmann 2008-02-19 15:08:44 EST
Created attachment 295328 [details]
xrandr -q output
Comment 2 Chris Siebenmann 2008-02-19 15:09:49 EST
Created attachment 295329 [details]
Xorg.0.log-working

The Xorg.0.log file from a working driver version (version 6.7.195-3.fc8,
from the Fedora 8 base install).
Comment 3 Chris Siebenmann 2008-02-19 15:11:17 EST
Created attachment 295330 [details]
Xorg.0.log-broken

The Xorg.0.log from version 6.7.197-1.fc8, which doesn't work.
This (and the last Xorg.0.log) were from sessions with no /etc/X11/xorg.conf
file.
Comment 4 Chris Siebenmann 2008-02-21 12:51:52 EST
In a spirit of experimentation, I built a 6.8.0 + git fixes version
of the driver and it did not have the problem with lighting the VGA
LCD panel. It still did have the problems with really slow performance
when EXA acceleration is enabled. (And other really slow performance
when EXA is *not* enabled, which is common to all driver versions and
the reason I want to use EXA.)

Just from reading 'git log' of the xorg-x11-drv-ati repository, I
suspect that panel issue is commit 8d64be6ebd7f50d4bcb587afeee8252c1367dc77,
but I have not tried to extract just this patch and testing it on
top of 6.7.197.
Comment 5 Ray Van Dolson 2008-02-23 03:16:19 EST
I believe I'm having this issue as well.  R350 based chip and after doing a
recent update (Fedora 8) only my DVI display is on although xrandr sees the VGA
display just fine and seems to think it's working.

When I exit X the VGA display comes back on again.
Comment 6 Ray Van Dolson 2008-02-23 09:36:47 EST
BTW Chris, do you have an SRPM of your "fixed" version?  Would be interested in
testing it on my machine.
Comment 7 Ray Van Dolson 2008-02-23 12:07:49 EST
I rebuild the 6.8.0 RPM's from rawhide for Fedora 8 and my VGA display once
again works.

http://www.bludgeon.org/~rayvd/rpms/xorg-x11-drv-ati/

Just had to remove the Requires and BuildRequires for the newer version of xorg.
Comment 8 Ray Van Dolson 2008-02-23 12:11:19 EST
Created attachment 295709 [details]
Xorg Log from 6.7.197 (VGA head doesn't come on)
Comment 9 Ray Van Dolson 2008-02-23 12:11:49 EST
Created attachment 295710 [details]
Xorg Log from 6.8.0 (VGA head comes on)
Comment 10 Bug Zapper 2008-11-26 04:52:36 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-01-09 02:40:05 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.