Bug 433541 - kernel stacktrace having to do with net ipv4
kernel stacktrace having to do with net ipv4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 16:59 EST by Andrew Farris
Modified: 2008-04-01 05:11 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.25-0.172.rc7.git4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 05:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2008-02-19 16:59:19 EST
Description of problem:
kernel stacktrace having to do with net ipv4

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.40.rc1.git2.fc9.i686

How reproducible:
not repeated yet

This was isolated in /var/log/messages by about 4 hours since anything else was
printed.  The machine was seeding torrents at the time, many connections but
bandwidth limited under 20kb, the network remained active and moving traffic for
5 hours afterward before I noticed this.

Feb 19 08:21:30 cirithungol kernel: ------------[ cut here ]------------
Feb 19 08:21:30 cirithungol kernel: WARNING: at net/ipv4/tcp_input.c:2506
tcp_ack+0xcb0/0x1803() (Not tainted)
Feb 19 08:21:30 cirithungol kernel: Modules linked in: appletalk rfcomm l2cap
bluetooth sunrpc ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr
iscsi_tcp libiscsi scsi_transport_iscsi ipt_REJECT ipt_LOG nf_conntrack_ipv4
iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6t_LOG xt_limit
nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables ipv6
fuse vfat fat xfs dm_mirror dm_multipath dm_mod firewire_sbp2 snd_usb_audio
snd_usb_lib dcdbas snd_emu10k1_synth snd_emux_synth snd_seq_virmidi
snd_seq_midi_emul floppy pcspkr serio_raw snd_intel8x0 snd_emu10k1 snd_rawmidi
snd_ac97_codec ac97_bus snd_seq_dummy i2c_i801 i2c_core snd_seq_oss
snd_seq_midi_event snd_seq arc4 ecb crypto_blkcipher snd_pcm_oss joydev
snd_mixer_oss snd_pcm rt2500pci intel_rng snd_seq_device iTCO_wdt rt2x00pci
rt2x00lib iTCO_vendor_support snd_timer 3c59x rfkill crc_ccitt snd_page_alloc
input_polldev mac80211 mii snd_util_mem firewire_ohci snd_hwdep tulip
firewire_core snd emu10k1_gp cfg80211 crc_itu_t gameport soundcore eep
Feb 19 08:21:30 cirithungol kernel: rom_93cx6 button sg sr_mod cdrom pata_acpi
ata_piix ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd
ehci_hcd [last unloaded: microcode]
Feb 19 08:21:30 cirithungol kernel: Pid: 0, comm: swapper Not tainted
2.6.25-0.40.rc1.git2.fc9 #1
Feb 19 08:21:30 cirithungol kernel:  [<c0429a8b>] warn_on_slowpath+0x47/0x75
Feb 19 08:21:30 cirithungol kernel:  [<c0484590>] ? add_partial+0x36/0x3b
Feb 19 08:21:30 cirithungol kernel:  [<c040a388>] ? native_sched_clock+0xb5/0xd1
Feb 19 08:21:30 cirithungol kernel:  [<c0445cc7>] ? mark_held_locks+0x4e/0x66
Feb 19 08:21:30 cirithungol kernel:  [<c063be40>] ?
_spin_unlock_irqrestore+0x40/0x50
Feb 19 08:21:30 cirithungol kernel:  [<c0445e39>] ? trace_hardirqs_on+0xd3/0x10a
Feb 19 08:21:30 cirithungol kernel:  [<c0431fc0>] ? __mod_timer+0xc5/0xd0
Feb 19 08:21:30 cirithungol kernel:  [<c05efb5c>] ? tcp_enter_frto_loss+0x163/0x1b8
Feb 19 08:21:30 cirithungol kernel:  [<c05f198d>] tcp_ack+0xcb0/0x1803
Feb 19 08:21:30 cirithungol kernel:  [<c05f52ab>] tcp_rcv_established+0x920/0xb8d
Feb 19 08:21:30 cirithungol kernel:  [<c05fb040>] tcp_v4_do_rcv+0x29c/0x425
Feb 19 08:21:30 cirithungol kernel:  [<c05fb69a>] tcp_v4_rcv+0x4d1/0x716
Feb 19 08:21:30 cirithungol kernel:  [<c05e3a2c>]
ip_local_deliver_finish+0x112/0x1d7
Feb 19 08:21:30 cirithungol kernel:  [<c05e3b52>] ip_local_deliver+0x61/0x6a
Feb 19 08:21:30 cirithungol kernel:  [<c05e36d4>] ip_rcv_finish+0x290/0x2af
Feb 19 08:21:30 cirithungol kernel:  [<c05e38f0>] ip_rcv+0x1fd/0x227
Feb 19 08:21:30 cirithungol kernel:  [<c05c6ff1>] netif_receive_skb+0x37f/0x3c2
Feb 19 08:21:30 cirithungol kernel:  [<c05c70c7>] process_backlog+0x93/0xec
Feb 19 08:21:30 cirithungol kernel:  [<c05c597e>] net_rx_action+0xcb/0x1fa
Feb 19 08:21:30 cirithungol kernel:  [<c042e81e>] __do_softirq+0x84/0x10a
Feb 19 08:21:30 cirithungol kernel:  [<c0408022>] do_softirq+0x79/0xda
Feb 19 08:21:30 cirithungol kernel:  [<c0462f7d>] ? handle_fasteoi_irq+0x0/0xb6
Feb 19 08:21:30 cirithungol kernel:  [<c042e384>] irq_exit+0x44/0x77
Feb 19 08:21:30 cirithungol kernel:  [<c040812f>] do_IRQ+0xac/0xc5
Feb 19 08:21:30 cirithungol kernel:  [<c04067ca>] common_interrupt+0x2e/0x34
Feb 19 08:21:30 cirithungol kernel:  [<c041ad63>] ? native_safe_halt+0x5/0x7
Feb 19 08:21:30 cirithungol kernel:  [<c0404d74>] default_idle+0x5a/0x9a
Feb 19 08:21:30 cirithungol kernel:  [<c0404d1a>] ? default_idle+0x0/0x9a
Feb 19 08:21:30 cirithungol kernel:  [<c0404cfa>] cpu_idle+0xc7/0xe7
Feb 19 08:21:30 cirithungol kernel:  [<c062c3bd>] rest_init+0x49/0x4b
Feb 19 08:21:30 cirithungol kernel:  =======================
Feb 19 08:21:30 cirithungol kernel: ---[ end trace 0c6384509be8d92d ]---


02:0a.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet
10/100 (rev 11)
	Subsystem: ADMtek Unknown device 0574
	Flags: bus master, medium devsel, latency 64, IRQ 19
	I/O ports at e800 [size=256]
	Memory at fe1fd800 (32-bit, non-prefetchable) [size=1K]
	Expansion ROM at fe100000 [disabled] [size=128K]
	Capabilities: [c0] Power Management version 2
	Kernel driver in use: tulip
	Kernel modules: tulip

02:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
	Subsystem: Dell Unknown device 010d
	Flags: bus master, medium devsel, latency 64, IRQ 18
	I/O ports at ec00 [size=128]
	Memory at fe1fcc00 (32-bit, non-prefetchable) [size=128]
	Expansion ROM at fe120000 [disabled] [size=128K]
	Capabilities: [dc] Power Management version 2
	Kernel driver in use: 3c59x
	Kernel modules: 3c59x
Comment 1 Andrew Farris 2008-02-21 04:29:28 EST
This happened again, although it is slightly different this time around.  Still
the system does not seem to have any problem with traffic moving after this
happened, 3 hours later it was still working fine. (yeah I rebooted when I
noticed it, but it was awhile because nothing seemed wrong)

Feb 20 22:20:00 cirithungol kernel: ------------[ cut here ]------------
Feb 20 22:20:00 cirithungol kernel: WARNING: at net/ipv4/tcp_input.c:2506
tcp_ack+0xcb0/0x1803() (Not tainted)
Feb 20 22:20:00 cirithungol kernel: Modules linked in: appletalk rfcomm l2cap
bluetooth fuse sunrpc ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr
iscsi_tcp libiscsi scsi_transport_iscsi ipt_REJECT ipt_LOG nf_conntrack_ipv4
iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6t_LOG xt_limit
nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables ipv6
vfat fat xfs dm_mirror dm_multipath dm_mod firewire_sbp2 snd_usb_audio
snd_usb_lib dcdbas snd_emu10k1_synth snd_emux_synth snd_seq_virmidi
snd_seq_midi_emul floppy pcspkr snd_emu10k1 serio_raw snd_intel8x0 snd_rawmidi
snd_ac97_codec ac97_bus snd_seq_dummy i2c_i801 i2c_core snd_seq_oss arc4
snd_seq_midi_event snd_seq ecb crypto_blkcipher joydev snd_pcm_oss snd_mixer_oss
snd_pcm snd_seq_device rt2500pci snd_timer rt2x00pci rt2x00lib snd_page_alloc
snd_util_mem rfkill firewire_ohci crc_ccitt tulip snd_hwdep 3c59x emu10k1_gp snd
firewire_core crc_itu_t soundcore input_polldev mii gameport mac80211 cfg80211
eeprom_93cx6 intel_rng iTCO_wdt iTCO_vendo
Feb 20 22:20:00 cirithungol kernel: r_support button sg sr_mod cdrom pata_acpi
ata_piix ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd
ehci_hcd [last unloaded: microcode]
Feb 20 22:20:00 cirithungol kernel: Pid: 0, comm: swapper Not tainted
2.6.25-0.40.rc1.git2.fc9 #1
Feb 20 22:20:00 cirithungol kernel:  [<c0429a8b>] warn_on_slowpath+0x47/0x75
Feb 20 22:20:00 cirithungol kernel:  [<c040a0ba>] ? sched_clock+0x8/0xb
Feb 20 22:20:00 cirithungol kernel:  [<c04446e5>] ? lock_release_holdtime+0x1a/0x115
Feb 20 22:20:00 cirithungol kernel:  [<c0484590>] ? add_partial+0x36/0x3b
Feb 20 22:20:00 cirithungol kernel:  [<c0445cc7>] ? mark_held_locks+0x4e/0x66
Feb 20 22:20:00 cirithungol kernel:  [<c048590e>] ? __slab_free+0xb2/0x2fc
Feb 20 22:20:00 cirithungol kernel:  [<c0445e39>] ? trace_hardirqs_on+0xd3/0x10a
Feb 20 22:20:00 cirithungol kernel:  [<c048700a>] ? kmem_cache_free+0x70/0x8b
Feb 20 22:20:00 cirithungol kernel:  [<c05c1f87>] ? __kfree_skb+0x63/0x66
Feb 20 22:20:00 cirithungol kernel:  [<c05c1f87>] ? __kfree_skb+0x63/0x66
Feb 20 22:20:00 cirithungol kernel:  [<c05f198d>] tcp_ack+0xcb0/0x1803
Feb 20 22:20:00 cirithungol kernel:  [<c05f52ab>] tcp_rcv_established+0x920/0xb8d
Feb 20 22:20:00 cirithungol kernel:  [<c05fb040>] tcp_v4_do_rcv+0x29c/0x425
Feb 20 22:20:00 cirithungol kernel:  [<c05fb69a>] tcp_v4_rcv+0x4d1/0x716
Feb 20 22:20:00 cirithungol kernel:  [<c05e3a2c>]
ip_local_deliver_finish+0x112/0x1d7
Feb 20 22:20:00 cirithungol kernel:  [<c05e3b52>] ip_local_deliver+0x61/0x6a
Feb 20 22:20:00 cirithungol kernel:  [<c05e36d4>] ip_rcv_finish+0x290/0x2af
Feb 20 22:20:00 cirithungol kernel:  [<c05e38f0>] ip_rcv+0x1fd/0x227
Feb 20 22:20:00 cirithungol kernel:  [<c05c6ff1>] netif_receive_skb+0x37f/0x3c2
Feb 20 22:20:00 cirithungol kernel:  [<c05c70c7>] process_backlog+0x93/0xec
Feb 20 22:20:00 cirithungol kernel:  [<c05c597e>] net_rx_action+0xcb/0x1fa
Feb 20 22:20:00 cirithungol kernel:  [<c042e81e>] __do_softirq+0x84/0x10a
Feb 20 22:20:00 cirithungol kernel:  [<c0408022>] do_softirq+0x79/0xda
Feb 20 22:20:00 cirithungol kernel:  [<c0462f7d>] ? handle_fasteoi_irq+0x0/0xb6
Feb 20 22:20:00 cirithungol kernel:  [<c042e384>] irq_exit+0x44/0x77
Feb 20 22:20:00 cirithungol kernel:  [<c040812f>] do_IRQ+0xac/0xc5
Feb 20 22:20:00 cirithungol kernel:  [<c04067ca>] common_interrupt+0x2e/0x34
Feb 20 22:20:00 cirithungol kernel:  [<c041ad63>] ? native_safe_halt+0x5/0x7
Feb 20 22:20:00 cirithungol kernel:  [<c0404d74>] default_idle+0x5a/0x9a
Feb 20 22:20:00 cirithungol kernel:  [<c0404d1a>] ? default_idle+0x0/0x9a
Feb 20 22:20:00 cirithungol kernel:  [<c0404cfa>] cpu_idle+0xc7/0xe7
Feb 20 22:20:00 cirithungol kernel:  [<c062c3bd>] rest_init+0x49/0x4b
Feb 20 22:20:00 cirithungol kernel:  =======================
Feb 20 22:20:00 cirithungol kernel: ---[ end trace d7feba9f5f00a23b ]---
Feb 21 01:26:07 cirithungol kerneloops: Submitted 1 kernel oopses to
www.kerneloops.org
Comment 2 Andrew Farris 2008-03-12 02:51:04 EDT
This still occurs about once a day.  The machine is seeding Fedora ISO torrents
all day, and running Folding@Home.  Occassionally the FAH client triggers this,
sometimes its something else (probably transmission).

Here it is running on kernel-2.6.25-0.90.rc3

Mar  9 05:43:35 cirithungol kernel: Pid: 14027, comm: FahCore_78.exe Not tainted
2.6.25-0.90.rc3.git5.fc9 #1
Mar  9 05:43:35 cirithungol kernel:  [<c0428957>] warn_on_slowpath+0x47/0x75
Mar  9 05:43:35 cirithungol kernel:  [<c0430b8a>] ? lock_timer_base+0x1f/0x3e
Mar  9 05:43:35 cirithungol kernel:  [<c05f4ea6>] ? tcp_snd_test+0x18/0xda
Mar  9 05:43:35 cirithungol kernel:  [<c05f4faa>] ? tcp_may_send_now+0x42/0x53
Mar  9 05:43:35 cirithungol kernel:  [<c05f0ed5>] tcp_ack+0xcb0/0x1803
Mar  9 05:43:35 cirithungol kernel:  [<c05f47f3>] tcp_rcv_established+0x920/0xb8d
Mar  9 05:43:35 cirithungol kernel:  [<c05fa588>] tcp_v4_do_rcv+0x29c/0x425
Mar  9 05:43:35 cirithungol kernel:  [<c05fabe2>] tcp_v4_rcv+0x4d1/0x716
Mar  9 05:43:35 cirithungol kernel:  [<c05e2f98>]
ip_local_deliver_finish+0x112/0x1d7
Mar  9 05:43:35 cirithungol kernel:  [<c05e30be>] ip_local_deliver+0x61/0x6a
Mar  9 05:43:35 cirithungol kernel:  [<c05e2c40>] ip_rcv_finish+0x290/0x2af
Mar  9 05:43:35 cirithungol kernel:  [<c05e2e5c>] ip_rcv+0x1fd/0x227
Mar  9 05:43:35 cirithungol kernel:  [<c05c6511>] netif_receive_skb+0x37f/0x3c2
Mar  9 05:43:35 cirithungol kernel:  [<c05c65e7>] process_backlog+0x93/0xec
Mar  9 05:43:35 cirithungol kernel:  [<c05c4e9e>] net_rx_action+0xcb/0x1fa
Mar  9 05:43:35 cirithungol kernel:  [<c042d612>] __do_softirq+0x84/0x10a
Mar  9 05:43:35 cirithungol kernel:  [<c0407fc6>] do_softirq+0x79/0xda
Mar  9 05:43:35 cirithungol kernel:  [<c0461d45>] ? handle_fasteoi_irq+0x0/0xb6
Mar  9 05:43:35 cirithungol kernel:  [<c042d178>] irq_exit+0x44/0x77
Mar  9 05:43:35 cirithungol kernel:  [<c04080d3>] do_IRQ+0xac/0xc5
Mar  9 05:43:35 cirithungol kernel:  [<c040676e>] common_interrupt+0x2e/0x34
Mar  9 05:43:35 cirithungol kernel:  =======================
Mar  9 05:43:35 cirithungol kernel: ---[ end trace e683105b75457ed3 ]---
Comment 3 Chuck Ebbert 2008-03-12 17:25:36 EDT
Still happening? Please post the latest trace if it is.
Comment 4 Andrew Farris 2008-03-15 04:19:50 EDT
I can easily reproduce this (waiting an hour or so at random) on kernels up to
kernel-2.6.25-0.90.rc3.git5.fc9.i686.  I have not yet seen it happen on
kernel-2.6.25-0.113.rc5.git2.fc9.i686 or on 0.105, but I could not run 0.105 for
very long due to init issues (the one caused by selinux I believe).

I'll keep watching for this, but it may have gone silent for now...
Comment 5 Andrew Farris 2008-03-15 04:58:05 EDT
Ok while the bug does not happen 'on its own', I can still reproduce bug# 431038
with kernel-2.6.25-0.113.rc5.git2.  I'm not sure whether these bugs are related
or not but both do involve the tulip driver.
Comment 6 Chuck Ebbert 2008-03-18 13:26:41 EDT
Is there anything in the log before the "cut here" line that says "assertion
failed" or something like that?
Comment 7 Andrew Farris 2008-03-18 13:45:39 EDT
Yes for the last one I have saved messages for.  I didn't notice it at the time
when I only copied the trace lines.  The log from comment #2 has this (no
entries before these for 40 minutes):

Mar  9 05:43:26 cirithungol kernel: KERNEL: assertion (packets <=
tp->packets_out) failed at net/ipv4/tcp_input.c (2139)
Mar  9 05:43:35 cirithungol kernel:last message repeated 2 times
Mar  9 05:43:35 cirithungol kernel: ------------[ cut here ]------------
Mar  9 05:43:35 cirithungol kernel: WARNING: at net/ipv4/tcp_input.c:2506
tcp_ack+0xcb0/0x1803() (Not tainted)

I don't know if that showed up any other time.
Comment 8 Andrew Farris 2008-03-18 13:55:11 EDT
Ok I went digging and that assertion happened again on the 11th.

Mar 11 05:00:52 cirithungol kernel: KERNEL: assertion (packets <=
tp->packets_out) failed at net/ipv4/tcp_input.c (
2139)
Mar 11 05:01:23 cirithungol kernel:last message repeated 3 times
Mar 11 05:02:23 cirithungol kernel:last message repeated 2 times
Mar 11 05:03:23 cirithungol kernel:last message repeated 3 times
Mar 11 05:03:49 cirithungol kernel: ------------[ cut here ]------------
Mar 11 05:03:49 cirithungol kernel: WARNING: at net/ipv4/tcp_input.c:2506
tcp_ack+0xcb0/0x1803() (Not tainted)
Mar 11 05:03:49 cirithungol kernel: Modules linked in: appletalk smsc47m192
hwmon_vid hwmon sunrpc ib_iser rdma_cm 
ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi
ipt_REJECT ipt_LOG nf_conntrack_ip
v4 iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6t_LOG xt_limit
nf_conntrack_ipv6 xt_state nf_conntrack ip6tabl
e_filter ip6_tables x_tables ipv6 fuse vfat fat xfs dm_mirror dm_multipath
dm_mod snd_usb_audio snd_usb_lib dcdbas 
snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul floppy pcspkr
serio_raw snd_intel8x0 snd_emu10k1
 i2c_i801 snd_rawmidi i2c_core snd_ac97_codec ac97_bus snd_seq_dummy usb_storage
snd_seq_oss snd_seq_midi_event snd
_seq arc4 snd_pcm_oss ecb crypto_blkcipher snd_mixer_oss snd_pcm snd_seq_device
rt2500pci snd_timer rt2x00pci snd_p
age_alloc rt2x00lib snd_util_mem joydev firewire_ohci rfkill snd_hwdep
firewire_core 3c59x snd emu10k1_gp mii crc_c
citt tulip crc_itu_t input_polldev soundcore gameport mac80211 cfg80211
eeprom_93cx6 button intel_rng iTCO_wdt i
Mar 11 05:03:49 cirithungol kernel: TCO_vendor_support sg sr_mod cdrom pata_acpi
ata_piix ata_generic libata sd_mod
 scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]
Mar 11 05:03:49 cirithungol kernel: Pid: 3911, comm: FahCore_78.exe Not tainted
2.6.25-0.90.rc3.git5.fc9 #1
Mar 11 05:03:49 cirithungol kernel:  [<c0428957>] warn_on_slowpath+0x47/0x75
Mar 11 05:03:49 cirithungol kernel:  [<c040a2f8>] ? native_sched_clock+0xb5/0xd1
Mar 11 05:03:49 cirithungol kernel:  [<c044499b>] ? mark_held_locks+0x4e/0x66
Mar 11 05:03:49 cirithungol kernel:  [<c063a790>] ?
_spin_unlock_irqrestore+0x40/0x50
Mar 11 05:03:49 cirithungol kernel:  [<c0444b0d>] ? trace_hardirqs_on+0xd3/0x10a
Mar 11 05:03:49 cirithungol kernel:  [<c0430db4>] ? __mod_timer+0xc5/0xd0
Mar 11 05:03:49 cirithungol kernel:  [<c05ef0a4>] ? tcp_enter_frto_loss+0x163/0x1b8
Mar 11 05:03:49 cirithungol kernel:  [<c05f0ed5>] tcp_ack+0xcb0/0x1803
Mar 11 05:03:49 cirithungol kernel:  [<c05f3fb4>] tcp_rcv_established+0xe1/0xb8d
Mar 11 05:03:49 cirithungol kernel:  [<c05fa588>] tcp_v4_do_rcv+0x29c/0x425
Mar 11 05:03:49 cirithungol kernel:  [<c05fabe2>] tcp_v4_rcv+0x4d1/0x716
Mar 11 05:03:49 cirithungol kernel:  [<c05e2f98>]
ip_local_deliver_finish+0x112/0x1d7
Mar 11 05:03:49 cirithungol kernel:  [<c05e30be>] ip_local_deliver+0x61/0x6a
Mar 11 05:03:49 cirithungol kernel:  [<c05e2c40>] ip_rcv_finish+0x290/0x2af
Mar 11 05:03:49 cirithungol kernel:  [<c05e2e5c>] ip_rcv+0x1fd/0x227
Mar 11 05:03:49 cirithungol kernel:  [<c05c6511>] netif_receive_skb+0x37f/0x3c2
Mar 11 05:03:49 cirithungol kernel:  [<c05c65e7>] process_backlog+0x93/0xec
Mar 11 05:03:49 cirithungol kernel:  [<c05c4e9e>] net_rx_action+0xcb/0x1fa
Mar 11 05:03:49 cirithungol kernel:  [<c042d612>] __do_softirq+0x84/0x10a
Mar 11 05:03:49 cirithungol kernel:  [<c0407fc6>] do_softirq+0x79/0xda
Mar 11 05:03:49 cirithungol kernel:  [<c0461d45>] ? handle_fasteoi_irq+0x0/0xb6
Mar 11 05:03:49 cirithungol kernel:  [<c042d178>] irq_exit+0x44/0x77
Mar 11 05:03:49 cirithungol kernel:  [<c04080d3>] do_IRQ+0xac/0xc5
Mar 11 05:03:49 cirithungol kernel:  [<c040676e>] common_interrupt+0x2e/0x34
Mar 11 05:03:49 cirithungol kernel:  =======================
Mar 11 05:03:49 cirithungol kernel: ---[ end trace d6443a000cf99001 ]---


In another case from Mar 10 no assertion showed up:

Mar 10 15:35:32 cirithungol kernel: FahCore_78.exe used greatest stack depth:
884 bytes left
Mar 10 18:51:03 cirithungol kernel: ------------[ cut here ]------------
Mar 10 18:51:03 cirithungol kernel: WARNING: at net/ipv4/tcp_input.c:2506
tcp_ack+0xcb0/0x1803() (Not tainted)
Mar 10 18:51:03 cirithungol kernel: Modules linked in: appletalk smsc47m192
hwmon_vid hwmon sunrpc ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr
iscsi_tcp libiscsi scsi_transport_iscsi ipt_REJECT ipt_LOG nf_conntrack_ipv4
iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6t_LOG xt_limit
nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables ipv6
fuse vfat fat xfs dm_mirror dm_multipath dm_mod snd_usb_audio snd_usb_lib dcdbas
floppy snd_emu10k1_synth snd_emux_synth pcspkr serio_raw snd_seq_virmidi
snd_seq_midi_emul snd_intel8x0 snd_emu10k1 i2c_i801 i2c_core snd_rawmidi
snd_ac97_codec ac97_bus snd_seq_dummy usb_storage snd_seq_oss snd_seq_midi_event
snd_seq joydev arc4 ecb snd_pcm_oss crypto_blkcipher snd_mixer_oss snd_pcm
snd_seq_device rt2500pci rt2x00pci snd_timer rt2x00lib snd_page_alloc
firewire_ohci snd_util_mem firewire_core rfkill snd_hwdep 3c59x crc_ccitt snd
mii input_polldev mac80211 crc_itu_t emu10k1_gp tulip soundcore gameport
cfg80211 eeprom_93cx6 button intel_rng iTCO_wdt i
Mar 10 18:51:03 cirithungol kernel: TCO_vendor_support sr_mod sg cdrom pata_acpi
ata_piix ata_generic libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd
ehci_hcd [last unloaded: microcode]
Mar 10 18:51:03 cirithungol kernel: Pid: 3204, comm: transmission Not tainted
2.6.25-0.90.rc3.git5.fc9 #1
Mar 10 18:51:03 cirithungol kernel:  [<c0428957>] warn_on_slowpath+0x47/0x75
Mar 10 18:51:03 cirithungol kernel:  [<c0483ee4>] ? check_object+0x130/0x184
Mar 10 18:51:03 cirithungol kernel:  [<c044499b>] ? mark_held_locks+0x4e/0x66
Mar 10 18:51:03 cirithungol kernel:  [<c0486529>] ? kmem_cache_free+0xba/0xcf
Mar 10 18:51:03 cirithungol kernel:  [<c0444b0d>] ? trace_hardirqs_on+0xd3/0x10a
Mar 10 18:51:03 cirithungol kernel:  [<c05c14a5>] ? __kfree_skb+0x63/0x66
Mar 10 18:51:03 cirithungol kernel:  [<c05c14a5>] ? __kfree_skb+0x63/0x66
Mar 10 18:51:03 cirithungol kernel:  [<c05f0ed5>] tcp_ack+0xcb0/0x1803
Mar 10 18:51:03 cirithungol kernel:  [<c05f3fb4>] tcp_rcv_established+0xe1/0xb8d
Mar 10 18:51:03 cirithungol kernel:  [<c05fa588>] tcp_v4_do_rcv+0x29c/0x425
Mar 10 18:51:03 cirithungol kernel:  [<c05fabe2>] tcp_v4_rcv+0x4d1/0x716
Mar 10 18:51:03 cirithungol kernel:  [<c05e2f98>]
ip_local_deliver_finish+0x112/0x1d7
Mar 10 18:51:03 cirithungol kernel:  [<c05e30be>] ip_local_deliver+0x61/0x6a
Mar 10 18:51:03 cirithungol kernel:  [<c05e2c40>] ip_rcv_finish+0x290/0x2af
Mar 10 18:51:03 cirithungol kernel:  [<c05e2e5c>] ip_rcv+0x1fd/0x227
Mar 10 18:51:03 cirithungol kernel:  [<c05c6511>] netif_receive_skb+0x37f/0x3c2
Mar 10 18:51:03 cirithungol kernel:  [<c05c65e7>] process_backlog+0x93/0xec
Mar 10 18:51:03 cirithungol kernel:  [<c05c4e9e>] net_rx_action+0xcb/0x1fa
Mar 10 18:51:03 cirithungol kernel:  [<c042d612>] __do_softirq+0x84/0x10a
Mar 10 18:51:03 cirithungol kernel:  [<c0407fc6>] do_softirq+0x79/0xda
Mar 10 18:51:03 cirithungol kernel:  [<c0461d45>] ? handle_fasteoi_irq+0x0/0xb6
Mar 10 18:51:03 cirithungol kernel:  [<c042d178>] irq_exit+0x44/0x77
Mar 10 18:51:03 cirithungol kernel:  [<c04080d3>] do_IRQ+0xac/0xc5
Mar 10 18:51:03 cirithungol kernel:  [<c040676e>] common_interrupt+0x2e/0x34
Mar 10 18:51:03 cirithungol kernel:  [<c04400d8>] ? timer_list_show+0x199/0x85a
Mar 10 18:51:03 cirithungol kernel:  [<c063a794>] ?
_spin_unlock_irqrestore+0x44/0x50
Mar 10 18:51:03 cirithungol kernel:  [<c04af04c>] sys_epoll_wait+0x223/0x3e0
Mar 10 18:51:03 cirithungol kernel:  [<c043e0db>] ? getnstimeofday+0x34/0xd1
Mar 10 18:51:03 cirithungol kernel:  [<c0405d85>] ? restore_nocheck+0x12/0x15
Mar 10 18:51:03 cirithungol kernel:  [<c0444b23>] ? trace_hardirqs_on+0xe9/0x10a
Mar 10 18:51:03 cirithungol kernel:  [<c0405d16>] syscall_call+0x7/0xb
Mar 10 18:51:03 cirithungol kernel:  =======================
Mar 10 18:51:03 cirithungol kernel: ---[ end trace 1717bbbcda26aae8 ]---


So both of the basic trace formats in this bug so far can have the assertion in
the log, but don't every time.
Comment 9 Dave Jones 2008-03-29 22:45:32 EDT
Is this still happening with the rc7 kernel ?
Comment 10 Andrew Farris 2008-03-30 17:26:18 EDT
I can't get the rc7 kernel to work, it fails to start with the vga=792 param I
usually use just giving a blank screen, but when I remove it I get the machine
booted to runlevel 3 (default is set to 5) and I have no keyboard input so the
machine has to be hard reset.  It also does not respond to ssh once it gets to
login prompt.

I'll look at this with the next rawhide kernel or if I manage to get rc7 booted
fine.
Comment 11 Andrew Farris 2008-04-01 05:11:08 EDT
Ok I got rc7 running and I've had torrents and FAH client running at the same
time on 2.6.25-0.172.rc7.git4.fc9.i686 for over 24 hours without this happening,
so this particular issue may be gone.  I'll close it for now.

Note You need to log in before you can comment on or make changes to this bug.