Bug 433551 - noarch builds w/o src rpm ignored for first listed arch
noarch builds w/o src rpm ignored for first listed arch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mash (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 18:09 EST by Peter Pramberger
Modified: 2014-03-16 23:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: mash-0.5.20-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (626 bytes, patch)
2008-02-19 18:09 EST, Peter Pramberger
no flags Details | Diff

  None (edit)
Description Peter Pramberger 2008-02-19 18:09:36 EST
Description of problem:

Mash has special handling built-in for noarch builds without src.rpm. However
due to a small logic error a noarch build for the first listed arch in the
config file is always ignored, resulting in missing rpms in the output dir.


Version-Release number of selected component (if applicable):

Tested with 0.2.10, but may apply to other versions too.


How reproducible:

Populate a tag in Koji with at least one noarch build (w/o src.rpm), create a
corresponding mash config with some archs (eg. "i386 x86_64") and run mash.


Actual results:

The mash output directory for the first arch (eg. "i386" in this example) is
missing the noarch rpm.
Comment 1 Peter Pramberger 2008-02-19 18:09:36 EST
Created attachment 295352 [details]
Fix
Comment 2 Bill Nottingham 2008-02-20 15:13:35 EST
Added in upstream git for rawhide, may make it back to the RHEL 5 branch at some
point. Thanks!
Comment 3 Fedora Update System 2008-04-11 10:18:33 EDT
mash-0.2.10-2.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-16 23:52:45 EDT
mash-0.2.10-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mash'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3109
Comment 5 Fedora Update System 2008-04-29 16:49:15 EDT
mash-0.2.10-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2010-05-07 13:54:01 EDT
mash-0.5.16-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/mash-0.5.16-1.el5
Comment 7 Fedora Update System 2010-09-28 12:19:02 EDT
mash-0.5.20-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mash-0.5.20-1.el5
Comment 8 Fedora Update System 2010-10-13 01:57:23 EDT
mash-0.5.20-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.