Bug 433569 - entries in /etc/services repeated
entries in /etc/services repeated
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vnc-ltsp-config (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 19:57 EST by Jonathan Underwood
Modified: 2008-02-20 12:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 12:33:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2008-02-19 19:57:23 EST
Description of problem:
After the recent updated package, I have the entries in the /etc/services file
twice:

vnc-1024x768x24 5900/tcp
vnc-800x600x16  5901/tcp
vnc-640x480x16  5902/tcp
vnc-1024x768x8  5903/tcp
vnc-800x600x8   5904/tcp
vnc-640x480x8   5905/tcp
vnc-1024x768x16 5900/tcp
vnc-800x600x16  5901/tcp
vnc-640x480x16  5902/tcp
vnc-1024x768x8  5903/tcp
vnc-800x600x8   5904/tcp
vnc-640x480x8   5905/tcp


Version-Release number of selected component (if applicable):
vnc-ltsp-config-4.0-4.fc8

How reproducible:
Everytime

Steps to Reproduce:
1.install older version of package
2.update
3.
Comment 1 Rex Dieter 2008-02-20 07:35:19 EST
Did you change it?  
I ask because the default config doesn't include any x24 modes, and the %post
check looks for x16, 

%post
if [ ! "`grep ^vnc-1024x768x16 %{_sysconfdir}/services`" ]; then
  cat %{_datadir}/vnc/vncts.services >> %{_sysconfdir}/services ||:
fi
Comment 2 Jonathan Underwood 2008-02-20 12:29:46 EST
Ah, yes, I guess I must have. 

I wonder if there's a more robust way of doing this - eg. by adding a section header

### VNCTS SECTION
stuff
### END OF VNCTS SECTION

and only adding it if the first line isnt there or something, so that updating
doesn't clobber user modified config.
Comment 3 Rex Dieter 2008-02-20 12:33:03 EST
Hee, the robust way is to not munge /etc/services *at all* :), which is what is
being done so far experimentally in rawhide.  When/if that works out, and gets
some testing/feedback, that implementation will likely find it's way into a
future update.

For now, I'll mark this as closed/worksforme, since we found the cause (which
wasn't the packaging, albeit fragile).

Note You need to log in before you can comment on or make changes to this bug.