Bug 433572 - GDM fails to start in VNC session
Summary: GDM fails to start in VNC session
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc-ltsp-config   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-20 01:31 UTC by Jonathan Underwood
Modified: 2008-02-20 19:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 19:27:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Underwood 2008-02-20 01:31:20 UTC
Description of problem:
Recently on F-8 GDM stopped appearing in a vncts-ltsp-config xinetd started vnc
session. The session starts fine, but in the vnc window i just get the
black/white checkring that you normally get just before GDM starts. GDM doesn't
start and present me with a login screen.

Version-Release number of selected component (if applicable):
gtk-vnc-0.3.2-2.fc8
vnc-server-4.1.2-23.fc8
gtk-vnc-python-0.3.2-2.fc8
vnc-libs-4.1.2-23.fc8
vnc-4.1.2-23.fc8
vnc-ltsp-config-4.0-4.fc8
gdm-2.20.3-1.fc8
fedorainfinity-gdm-theme-8.0.1-1.fc8

[same versions on both server and client - both fully updated F-8 nistalls.]

How reproducible:
Everytime

Steps to Reproduce:
1.install vncts-ltsp-config on server, and start xinetd service
2.on local client do vncviewer -FullColour -via server.address.com localhost::5900
3.
  
Actual results:
vnc session starts, but the GDM login never appears. 

Expected results:
vnc sessions starts, gdm appears

Additional info:
Not sure if this is a vnc or a gdm bug...

Comment 1 Jonathan Underwood 2008-02-20 01:32:58 UTC
Corresponding lines in /var/log/messages:

Feb 20 01:21:12 withnail xinetd[13680]: xinetd Version 2.3.14 started with
libwrap loadavg labeled-networking options compiled in.
Feb 20 01:21:12 withnail xinetd[13680]: Started working: 3 available services
Feb 20 01:21:25 withnail xinetd[13680]: START: vnc pid=13686 from=::ffff:127.0.0.1
Feb 20 01:22:48 withnail ntpd[2278]: synchronized to 144.82.100.59, stratum 2
Feb 20 01:23:31 withnail xinetd[13680]: EXIT: vnc status=0 pid=13686
duration=126(sec)


Comment 2 Rex Dieter 2008-02-20 13:09:24 UTC
The symptom(s) you're describing seem to indicate that you haven't enabled XDMCP
in your LOGINMANAGER (gdm).  By default, XDMCP is disabled, but is required for
vnc-ltsp-config to work.  Please confirm.

Comment 3 Jonathan Underwood 2008-02-20 17:07:30 UTC
In gdmsetup I have enabled remote login .. so I think xdmcp is enabled.

Comment 4 Jonathan Underwood 2008-02-20 19:27:17 UTC
xdmcp is indeed enabled (checked in /etc/gdm/custom.conf).

However, what I found just now was that doing init 3 && init 5 to restart GDM
fixed the problem. Not really sure what is going on, but I am confident this is
not a bug in vncts-ltsp-config, so closing. Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.