Bug 433624 - logwatch generates false messages about yum
logwatch generates false messages about yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 08:29 EST by Raffael Luthiger
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 10:57:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raffael Luthiger 2008-02-20 08:29:29 EST
Description of problem:
logwatch sends some false information about "newly installed packages" because
there is no "year" in the log file.

example log file entry (from a F7 machine):
[root@host ~]# tail /var/log/yum.log
Feb 20 12:50:00 Updated: wine-esd - 0.9.55-1.fc7.i386
Feb 20 12:50:01 Updated: wine-tools - 0.9.55-1.fc7.i386

Part of the logwatch email:
 --------------------- yum Begin ------------------------ 

 
 Packages Updated:
    rsync.i386 2.6.9-2.fc5
 
 ---------------------- yum End ------------------------- 


This information is totally wrong. I updated this package exactly one year ago.

I guess most developers of Fedora are always with the newest version of Fedora
and therefore update with yum very often. The logfile is therefore cleaned up
very often and they never get into the situation that the information in the log
file is older than a year.

The solution would be to add the year to the log string. Another solution would
be to change the logwatch parser so it makes more checks if the information is
really new (at the end of the file)
Comment 1 Seth Vidal 2008-02-21 10:57:59 EST
take this to logwatch. please ask them to get the yum log information from
/var/log/messages - not out of the yum.log.

Note You need to log in before you can comment on or make changes to this bug.