Bug 433626 - Firefox and xulrunner version mismatch
Summary: Firefox and xulrunner version mismatch
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-20 13:39 UTC by Michel Alexandre Salim
Modified: 2008-02-23 02:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-23 02:52:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michel Alexandre Salim 2008-02-20 13:39:25 UTC
Description of problem:
The current version of Firefox in Rawhide is a 3.0b4pre, and as such the 
xulrunner dependency has been bumped up. The corresponding version of xulrunner 
in Rawhide is older (see version numbers below), so Firefox aborts when started.

(Curious: was this not detected at compile time? Or was Firefox compiled with a 
newer version of xulrunner, but for some reason the proper Requires: is not 
automatically detected?)

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta3.22.nightly20080215.fc9
xulrunner-1.9-0.beta2.12.nightly20080121.fc9

How reproducible:
Always

Steps to Reproduce:
1. yum install firefox
2. firefox
  
Actual results:
Error: Platform version '1.9b3pre' is not compatible with
minVersion >= 1.9b4pre
maxVersion <= 1.9b4pre

Expected results:
Should work. Or should not have installed, since the matching xulrunner is not 
in Rawhide

Additional info:

Comment 1 Michel Alexandre Salim 2008-02-22 18:57:55 UTC
Works with the current xulrunner. Still, shouldn't the xulrunner package provides a more fine-grained API 
version (something in-between the current gecko-libs=1.9 and xulrunner=1.9.0-beta3.bla) that the 
firefox package can then Requires: ? That way we won't get mismatched updates.

Problem should be moot with stable versions, anyway.

Comment 2 Christopher Aillon 2008-02-23 02:52:37 UTC
I'm just evil and want to get people in the habit of yum updateing both.  :-)

This won't be an issue in the final builds, you're right.  Closing this one out.


Note You need to log in before you can comment on or make changes to this bug.