Description of problem:
The current version of Firefox in Rawhide is a 3.0b4pre, and as such the
xulrunner dependency has been bumped up. The corresponding version of xulrunner
in Rawhide is older (see version numbers below), so Firefox aborts when started.
(Curious: was this not detected at compile time? Or was Firefox compiled with a
newer version of xulrunner, but for some reason the proper Requires: is not
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. yum install firefox
Error: Platform version '1.9b3pre' is not compatible with
minVersion >= 1.9b4pre
maxVersion <= 1.9b4pre
Should work. Or should not have installed, since the matching xulrunner is not
Works with the current xulrunner. Still, shouldn't the xulrunner package provides a more fine-grained API
version (something in-between the current gecko-libs=1.9 and xulrunner=1.9.0-beta3.bla) that the
firefox package can then Requires: ? That way we won't get mismatched updates.
Problem should be moot with stable versions, anyway.
I'm just evil and want to get people in the habit of yum updateing both. :-)
This won't be an issue in the final builds, you're right. Closing this one out.