Bug 433627 - strigidaemon don't start: Unknown backend type: clucene
strigidaemon don't start: Unknown backend type: clucene
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 08:54 EST by Sebastian Vahl
Modified: 2008-03-03 13:24 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.8-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 13:24:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-02-20 08:54:40 EST
Description of problem:
strigidaemon is not able to start. The error message is:
Unknown backend type: clucene

Also "strigidaemon --backends" don't list any backends.

Version-Release number of selected component (if applicable):
strigi-0.5.7-1.fc8.x86_64
strigi-libs-0.5.7-1.fc8.x86_64
clucene-core-0.9.20-2.fc8.x86_64

How reproducible:
ever

Steps to Reproduce:
1. start "strigidaemon" from a terminal
  
Actual results:
no starting


Expected results:
should start

Additional info:
build log of actual version has not really found clucene:
-- Found CLucene library: /usr/lib64/libclucene.so
-- Found CLucene include dir: /usr/include
Could not find CLucene. Please install CLucene = 0.9.16a 
(http://clucene.sf.net)
http://koji.fedoraproject.org/packages/strigi/0.5.7/1.fc8/data/logs/x86_64/build.log

But also a local rebuilt without this error stops with the same error message.
Comment 1 Fedora Update System 2008-02-20 10:03:48 EST
strigi-0.5.7-2.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-02-20 10:04:31 EST
strigi-0.5.7-2.fc7 has been submitted as an update for Fedora 7
Comment 3 Sebastian Vahl 2008-02-20 11:41:18 EST
As I've said, a simple rebuilt don't fix the main problem. Only the build 
error is gone.
Comment 4 Kevin Kofler 2008-02-20 11:45:53 EST
The build error sounds like badly broken too though.
But why is it still not finding the backend? Multilib issue maybe?
Comment 5 Deji Akingunola 2008-02-20 12:18:09 EST
(In reply to comment #3)
> As I've said, a simple rebuilt don't fix the main problem. Only the build 
> error is gone.

O.K, maybe I don't understand you at first, however this rebuild is necessary too.
Comment 6 Fedora Update System 2008-02-20 21:54:57 EST
strigi-0.5.7-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update strigi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1874
Comment 7 Sebastian Vahl 2008-02-21 03:26:15 EST
(In reply to comment #4)
> The build error sounds like badly broken too though.
> But why is it still not finding the backend? Multilib issue maybe?

Just tried it in i386. Same problem.

Comment 8 Kevin Kofler 2008-02-21 03:33:39 EST
Upstream released 0.5.8 2 days ago, maybe that fixes it. Should I try 
submitting builds for that?
Comment 9 Sebastian Vahl 2008-02-21 04:49:24 EST
(In reply to comment #8)
> Upstream released 0.5.8 2 days ago, maybe that fixes it. Should I try 
> submitting builds for that?

I've rebuilt strigi-0.8.2 locally and the problem still occurs (only tested i386).

clucene-core-0.9.20-2.fc8
strigi-0.5.8-1.fc8
strigi-libs-0.5.8-1.fc8


Comment 10 Kevin Kofler 2008-02-21 05:31:57 EST
I see the problem: This is due to an error in the hand-coded cmake invocation:
-DLIB_DESTINATION=lib%{lib_suffix}
LIB_DESTINATION should be an absolute path, i.e.:
-DLIB_DESTINATION=%{_libdir}
Comment 11 Kevin Kofler 2008-02-21 06:15:09 EST
Can you please try this build?
http://koji.fedoraproject.org/koji/buildinfo?buildID=38754
Comment 12 Sebastian Vahl 2008-02-21 06:26:53 EST
Confirmed to work on i386 and x86_64. Thanks!
Comment 13 Fedora Update System 2008-02-21 06:35:49 EST
strigi-0.5.8-1.fc8 has been submitted as an update for Fedora 8
Comment 14 Fedora Update System 2008-02-21 06:36:15 EST
strigi-0.5.8-1.fc7 has been submitted as an update for Fedora 7
Comment 15 Fedora Update System 2008-03-03 13:23:34 EST
strigi-0.5.8-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-03-03 13:24:35 EST
strigi-0.5.8-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.