Bug 433693 - Write only(dropbox) directories in shares do not allow access to when mounted using windows, Nautilus, or Mac OS X.
Write only(dropbox) directories in shares do not allow access to when mounted...
Status: CLOSED DUPLICATE of bug 497156
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Guenther Deschner
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 16:33 EST by David Miller
Modified: 2010-04-26 10:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 10:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Miller 2008-02-20 16:33:25 EST
Description of problem:
write only directories(other permissions set to write and execute only) do not
allow users to drag and drop items on them when mounted using a Windows client,
or mounted using nautilus under RHEL5, or mounted under a Mac OS X client.
Mounting the share using the mount.cifs in RHEL5.1 does allow for items to be
drag and dropped, using the mv or cp command, and also the touch command.

Version-Release number of selected component (if applicable):

3.0.25b-1.el5_1.4

How reproducible:

This is very easily reproducable.

Steps to Reproduce:
1. setup a samba share and at least one samba user account that can access the
share.
2. inside the share create a directory called dropbox. Give it the following
permissions. chmod go=wx ./dropbox
3. Connect to the share using a windows2000,XP, or Vista client.

4. drag and drop a simple text file on the dropbox directory.
  
Actual results:

an Error dialog saying access denied

Expected results:

File is copied into the dropbox directory

Additional info:

RHEL5 with samba version 3.0.23c-2 did not have this problem.
Comment 3 Dmitri Pal 2010-04-26 10:40:21 EDT

*** This bug has been marked as a duplicate of bug 497156 ***

Note You need to log in before you can comment on or make changes to this bug.