Bug 433702 - nfs read-only root errors
nfs read-only root errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 17:05 EST by Andrew Hecox
Modified: 2010-10-22 18:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:15:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rc.sysinit patch (1.83 KB, patch)
2008-02-20 17:05 EST, Andrew Hecox
no flags Details | Diff
network init patch (659 bytes, patch)
2008-02-20 17:05 EST, Andrew Hecox
no flags Details | Diff
halt patch (1.26 KB, patch)
2008-02-20 17:06 EST, Andrew Hecox
no flags Details | Diff
rwtab addendum (274 bytes, patch)
2008-02-20 17:06 EST, Andrew Hecox
no flags Details | Diff

  None (edit)
Description Andrew Hecox 2008-02-20 17:05:08 EST
The following are a list of issues associated with a "stateless" read-only nfs
root disk. The test case was a diskless ppc blade, using a tmpfs RW_MOUNT and no
STATE_MOUNT. I have tested all of these changes on this test system but not on
any other architectures; however, I believe them to be generally applicable in
read-only nfs root configurations.

Changes to init scripts to better support stateless:

--rc.sysinit--

 - don't update mtab in a r/o root
 - mount on sys and /dev/pts returns EBUSY on a readonly root
 - [ -n $CLIENTSTATE ] is always returning true, causing an unnecessary timeout

--network--

 - /etc/mtab may not have any mount information in the readonly-root
   cause, but the root mount is likely to be a network mount.  Without
   this, nfs hangs the reboot process.

--halt-- 

 - don't try and update a read-only mtab 

--rwtab--

 - /var/empty/sshd/etc/localtime needs to be overwritten by sshd at
   startup
 - /var/lib/random-seed is written to at shutdown; this fixes the 
   error but doesn't return the functionality lost in a r/o /var/lib.
Comment 1 Andrew Hecox 2008-02-20 17:05:08 EST
Created attachment 295456 [details]
rc.sysinit patch
Comment 2 Andrew Hecox 2008-02-20 17:05:45 EST
Created attachment 295457 [details]
network init patch
Comment 3 Andrew Hecox 2008-02-20 17:06:10 EST
Created attachment 295458 [details]
halt patch
Comment 4 Andrew Hecox 2008-02-20 17:06:28 EST
Created attachment 295459 [details]
rwtab addendum
Comment 5 RHEL Product and Program Management 2008-06-02 16:17:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Bill Nottingham 2008-06-12 14:06:22 EDT
Acking, but some of the patches need more investigation.
Comment 8 Michael Spiegle 2008-07-17 17:03:09 EDT
Regarding mount issue:
I believe other distributions have solved the mount/lockfile issue by using a
patched version of mount that doesn't create lockfiles in RO-root situations.

Regarding /etc/mtab:
Since other tools/utilities might need information in /etc/mtab, I think it
might be more appropriate to symlink it to /proc/mounts.  I noticed that the
netboot root preparation tool from Redhat appears to do this already.

Thanks for the patches Andrew!
Comment 17 errata-xmlrpc 2009-01-20 17:15:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0245.html

Note You need to log in before you can comment on or make changes to this bug.