Bug 433747 - Missing Python module: acutil
Summary: Missing Python module: acutil
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: freeIPA
Classification: Retired
Component: ipa-python
Version: unspecified
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 429034
TreeView+ depends on / blocked
 
Reported: 2008-02-21 05:44 UTC by W. Michael Petullo
Modified: 2015-01-04 23:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-06 15:39:34 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2008-02-21 05:44:31 UTC
Description of problem:
I installed ipa-server-0.99-9.fc9.ppc on a Fedora 8 system using yum. The
ipa-server-install script fails because the installation of ipa-server did not
pull in the Python acutil module as a dependency.

Version-Release number of selected component (if applicable):
ipa-python-0.99-9.fc9.ppc

How reproducible:
Every time

Steps to Reproduce:
1. Use yum to install ipa-server and its dependencies.
2. Run ipa-server-install.
  
Actual results:
Install script will fail because one of the utilities used requires the
dnsclient module which requires the acutil module. The acutil module does not exist.

Expected results:
The ipa-python package should require the acutil module.

Additional info:

Comment 1 W. Michael Petullo 2008-02-22 13:56:35 UTC
The acutil module is provided by the authconfig package, so this package should
be required by ipa-python.

Comment 2 Fedora Update System 2008-02-22 22:11:38 UTC
ipa-0.99-10.fc7 has been submitted as an update for Fedora 7

Comment 3 Fedora Update System 2008-02-22 22:12:07 UTC
ipa-0.99-10.fc8 has been submitted as an update for Fedora 8

Comment 4 Fedora Update System 2008-02-26 00:23:14 UTC
ipa-0.99-10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ipa'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1931


Note You need to log in before you can comment on or make changes to this bug.