Bug 433760 - installer hangs when running pup
installer hangs when running pup
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.1.z
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 05:54 EST by Need Real Name
Modified: 2009-02-20 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 17:53:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fichier contenant l'ensemble des messages d'erreurs (1.42 KB, application/octet-stream)
2008-02-21 05:56 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2008-02-21 05:54:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.0.12) Gecko/20080201 Red Hat/1.5.0.12-9.el5 Firefox/1.5.0.12

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.type the command pup
2.
3.

Actual Results:
an error occurs

Expected Results:


Additional info:
Comment 1 Need Real Name 2008-02-21 05:56:45 EST
Created attachment 295496 [details]
fichier contenant l'ensemble des messages d'erreurs
Comment 2 Clifford Perry 2009-02-20 16:52:29 EST
This was caused by a temporary server side issue with RHN and not the client, reporting the error back. This is not a bug with client side. 

[cperry@cperry ~]$ cat bug-21-02 
Component: Software Updater
Summary: TB7e17c70f rhnplugin.py:235:_getFile:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-x86_64-server-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in ?
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 324, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 380, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 228, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 622, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 235, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-x86_64-server-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: None
self: rhel-x86_64-server-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 0xc603ad0>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-x86_64-server-5/updateinfo.xml.gz
Comment 3 RHEL Product and Program Management 2009-02-20 17:53:13 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.