Bug 433769 - missing dependency on gecko-libs = 1.8.1.12
missing dependency on gecko-libs = 1.8.1.12
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: devhelp (Show other bugs)
7
All Linux
high Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 07:20 EST by Debarshi Ray
Modified: 2009-05-22 04:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-23 05:25:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Debarshi Ray 2008-02-21 07:20:56 EST
Description of problem:

Anjuta fails to build on F-7
(http://koji.fedoraproject.org/koji/taskinfo?taskID=435695) due to a devhelp's
dependency on gecko-libs = 1.8.1.12, which is missing:
http://koji.fedoraproject.org/koji/getfile?taskID=435707&name=root.log

For the time being I can by-pass this by disabling Anjuta's devhelp
plugin in F-7, but is it possible to fix the missing dependency?


Version-Release number of selected component (if applicable):

0.13-13.fc7

How reproducible:

Install or update to devhelp-0.13-13.fc7.
  

Actual results:

Error: Missing Dependency: gecko-libs = 1.8.1.12 is needed by package devhelp


Expected results:

Dependencies should be satisfied.
Comment 1 Debarshi Ray 2008-02-21 07:21:12 EST
Similar problem in F-8 too:
https://www.redhat.com/archives/fedora-devel-list/2008-February/msg01762.html
Comment 2 Matthew Barnes 2008-02-21 15:47:13 EST
Did caillon's update help?

This is starting to smell like an RPM problem.  I see in Koji the latest firefox
provides gecko-libs and firefox-devel provides gecko-devel, yet when I recompile
devhelp with gecko build requirements Koji seems to refuse to pull in firefox.

CC'ing caillon
Comment 3 Christopher Aillon 2008-02-21 16:31:46 EST
https://www.redhat.com/archives/fedora-devel-list/2008-February/msg01807.html

If that didn't fix it, there's a problem with koji or something else, not the
packages.
Comment 4 Matthew Barnes 2008-02-21 16:39:16 EST
Latest attempt to rebuild devhelp for F-7:
http://koji.fedoraproject.org/koji/buildinfo?buildID=38960

Gecko version is correct and the build requirements are unchanged, yet Koji does
not pull in any firefox packages (see the root.logs).  I agree with caillon.
Comment 5 Christopher Aillon 2008-02-21 17:24:38 EST
Started	Thu, 21 Feb 2008 09:08:06 MST
Completed	Thu, 21 Feb 2008 09:14:58 MST

My email was Date: Thu, 21 Feb 2008 11:00:23 -0500

only 6 minutes prior.  My statement was that  "It should be shown as fixed in
koji in about 30 minutes."
Comment 6 Matthew Barnes 2008-02-21 18:57:58 EST
Debarshi, can you try rebuilding the Anjuta packages again?
Comment 7 Debarshi Ray 2008-02-22 00:56:04 EST
Thank you for the prompt response. I am in office now. I shall try rebuilding
the Anjuta packages when I have access to my workstation later tonight.
Comment 8 Debarshi Ray 2008-02-23 03:08:52 EST
Trying to install Epiphany on Fedora 8 x86_64 gets me:

# yum -y --enablerepo=fedora --enablerepo=updates install epiphany
[...]
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 epiphany                x86_64     2.20.2-3.fc8     updates           5.3 M
Updating:
 firefox                 i386       2.0.0.12-1.fc8   updates            21 M
 firefox                 x86_64     2.0.0.12-1.fc8   updates            21 M
Updating for dependencies:
 devhelp                 x86_64     0.16.1-5.fc8     updates           199 k
 devhelp-devel           x86_64     0.16.1-5.fc8     updates            14 k
 firefox-devel           x86_64     2.0.0.12-1.fc8   updates           3.5 M
 gnome-python2-gtkmozembed  x86_64     2.19.1-12.fc8    updates            30 k
 yelp                    x86_64     2.20.0-7.fc8     updates           715 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       7 Package(s)         
Remove       0 Package(s)         

Total download size: 52 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package devhelp needs gecko-libs = 1.8.1.10, this is not available.
Package devhelp needs gecko-libs = 1.8.1.10, this is not available.
Complete!
Comment 9 Debarshi Ray 2008-02-23 03:14:32 EST
And then:

# yum clean all
Cleaning up Everything
# yum -y --disablerepo=updates --enablerepo=fedora install epiphany
[...]
Resolving Dependencies
--> Running transaction check
---> Package epiphany.x86_64 0:2.20.1-3.fc8 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.8 for package: epiphany
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.1.8 is needed by package epiphany
Comment 10 Debarshi Ray 2008-02-23 05:25:06 EST
(In reply to comment #6)

> Debarshi, can you try rebuilding the Anjuta packages again?

The Fedora 7 Anjuta issue seems to be fixed now:
http://koji.fedoraproject.org/koji/taskinfo?taskID=463609

The Epiphany installation issue also seems to be fixed. That must have been a
case of mirrors not being updated.

I marking this as WORKSFORME.
Comment 11 Greg Harvey 2009-05-22 04:32:07 EDT
Hmmm, Fedora 10, same issue. Installing epiphany-2.24.1-2.fc10.i386 wants gecko-libs-1.9.0.4 but it isn't in the repo at all.

Note You need to log in before you can comment on or make changes to this bug.