Bug 433775 - Build of wesnoth dies, says SDL_mixer lacks OGG support.
Summary: Build of wesnoth dies, says SDL_mixer lacks OGG support.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL_mixer   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-21 12:57 UTC by Gwyn Ciesla
Modified: 2008-02-22 20:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 19:24:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build log (10.35 KB, application/octet-stream)
2008-02-21 12:57 UTC, Gwyn Ciesla
no flags Details

Description Gwyn Ciesla 2008-02-21 12:57:59 UTC
Description of problem:


Version-Release number of selected component (if applicable):
1.2.8-8.fc9

How reproducible:
Mock rawhide build of wesnoth 1.3.16, not yet in cvs.


Actual results:
Attaching build.log

Expected results:
Successful build

Additional info:

Comment 1 Gwyn Ciesla 2008-02-21 12:57:59 UTC
Created attachment 295502 [details]
mock build log

Comment 2 Gwyn Ciesla 2008-02-21 12:59:10 UTC
Also, local build on F-8 succeeds, SDL_mixer version 1.2.8-6.

Comment 3 Brian Pepple 2008-02-22 19:24:39 UTC
SDL_mixer *does* have ogg support built-in.  The wesnoth test for ogg support in
it's configure script doesn't work in a chroot env.  Remove the test, and it
should compile fine. 

Marking as NOTABUG.

Comment 4 Gwyn Ciesla 2008-02-22 19:28:29 UTC
Ok, thanks very much, I'll try that.

Comment 5 Brian Pepple 2008-02-22 19:35:05 UTC
Look at the rawhide spec file.  There's a patch file there to remove it which
should help you.

Comment 6 Gwyn Ciesla 2008-02-22 20:07:23 UTC
I had originally removed that since it failed to apply, I assumed (incorrectly)
that the issue had been fixed upstream.

Comment 7 Brian Pepple 2008-02-22 20:37:16 UTC
(In reply to comment #6)
> I had originally removed that since it failed to apply, I assumed (incorrectly)
> that the issue had been fixed upstream.

Yeah, you'll need to make a new patch, since I'm sure configure.in has changed
in the new branch.



Comment 8 Gwyn Ciesla 2008-02-22 20:45:39 UTC
Indeed it has.  I've remade the patch, and I am doing a local build now, and I
will then do a mock test before importing and building in rawhide.

Can't believe I missed that. . .


Note You need to log in before you can comment on or make changes to this bug.