Bug 433777 - anaconda fails to run with --rootpath option
anaconda fails to run with --rootpath option
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 08:13 EST by Alexander Todorov
Modified: 2008-02-21 15:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 15:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-02-21 08:13:14 EST
Description of problem:
when executed with the --rootpath option anaconda will fail

Version-Release number of selected component (if applicable):
anaconda-11.1.2.101-1

How reproducible:
Always

Steps to Reproduce:
1. /usr/sbin/anaconda --rootpath=/root/anaconda --method=http://server/tree
  
Actual results:
[root@ibm-alishan ~]# /usr/sbin/anaconda --rootpath=/root/anaconda
--method=http://server/tree
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 614, in ?
    instClass = getInstClass(opts)
  File "/usr/sbin/anaconda", line 363, in getInstClass
    retval = cobject(flags.expert)
  File "/usr/lib/anaconda/installclasses/rhel.py", line 163, in __init__
    self.tasks = self.taskMap[productPath.lower()]
KeyError: 'anaconda'


Expected results:
Anaconda runs and proceeds with installation. 

Additional info:
Both anaconda and anaconda-runtime packages are installed.
SELinux is in permissive mode. Host has the same OS version as in
http://server/tree. Trying to install the packages in a directory.

The above works for Fedora8 host/tree.
Comment 2 Joel Andres Granados 2008-02-21 10:35:06 EST
This does not happen because of changes made for RHEL5.2,  thie bug appears in
RHEL5.1.
Comment 3 Alexander Todorov 2008-02-21 10:39:19 EST
Also appears in RHEL 5 GA
Comment 4 Joel Andres Granados 2008-02-21 15:06:58 EST
This works well in Fedora.
Additionally to make this work in RHEL5 there would have to be a big effort and
IMO it would not be worth it given the importance of the bug.

Note You need to log in before you can comment on or make changes to this bug.