Bug 43380 - IDE CDROM not detected
Summary: IDE CDROM not detected
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xcdroast   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-04 16:18 UTC by Dmitri A. Sergatskov
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 20:19:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitri A. Sergatskov 2001-06-04 16:18:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
I have IDE CDROM and SCSI CDRW. The xcdroast setup would not find
IDE CDROM, but finds SCSI CD-RW. It does not matter if CD-ROM will
have CD in it and if this CD is mounted or not. The older version of
xcdroast would not detect emty drive, but will find it if it has 
a mounted CD in it.

How reproducible:
Always

Steps to Reproduce:
1.run xcdroast (I do it as root)
2.click "Setup"
3.SCSI CD-R is there but not an IDE CDROM
	

Additional info:

This is a SuperMicro P6DGE motherboard (dual PIII / intel 440GX
chipset). SCSI is an add-on card -- Adaptec AHA-2940.
CDRW -- YAMAHA   Model: CRW8824S
CD-ROM is /dev/hdb.
cat /proc/ide/hdb/model    
CRD-8160B

Comment 1 Karsten Hopp 2001-06-05 09:20:10 UTC
The new cdrecord uses scsi-commands to interact with the CD drives. Therefore
loading the ide-scsi module is mandatory.
Please try to unload the ide-cd and the ide-scsi module (you may need to stop
magicdev or autorun) and reload the ide-scsi module.
Does the ATAPI reader show up now ?


Comment 2 Dmitri A. Sergatskov 2001-06-05 19:08:55 UTC
I do not use any desctop (Gnome or otherwise) just a windowmanager
(enlightenment). So I assume I do not have neither magic-dev nor
autorun running. I usually mount and unmount devices by hand. 
I tried to load (insmod ide-scsi) and run xcdroast again.
Did not see any changes. here is lsmod output:

Module                  Size  Used by
sg                     27776   0  (autoclean)
ide-scsi                8544   0 
ide-cd                 26944   1  (autoclean)
cdrom                  27392   0  (autoclean) [ide-cd]
nfsd                   70976   8  (autoclean)
autofs                 11808   1  (autoclean)
nfs                    82816   4  (autoclean)
lockd                  53232   1  (autoclean) [nfsd nfs]
sunrpc                 66352   1  (autoclean) [nfsd nfs lockd]
8139too                16880   1  (autoclean)
nls_iso8859-1           2880   2  (autoclean)
nls_cp437               4384   1  (autoclean)
vfat                    9488   1  (autoclean)
fat                    33856   0  (autoclean) [vfat]
aic7xxx               136336   0 
sd_mod                 11744   0  (unused)
scsi_mod               98624   4  [sg ide-scsi aic7xxx sd_mod]


Comment 3 Karsten Hopp 2001-06-05 19:36:37 UTC
You really have to unload the ide-cd and the ide-scsi modules before you reload the ide-scsi module.
Otherwise you won't see any changes in xcdroast.

Comment 4 Dmitri A. Sergatskov 2001-06-05 20:19:35 UTC
That worked. So, what should I do to make it work automagically?
Should I load ide-scsi before ide-cd (at boot time)?


Comment 5 Karsten Hopp 2001-08-23 14:14:06 UTC
You can add a line to your /etc/lilo.conf:
append="hdb=ide-scsi"

But you also have to change the link /dev/cdrom to point to /dev/scd0,
because you can't access hdb anymore when it is handled by ide-scsi.


Comment 6 Dmitri A. Sergatskov 2001-08-23 16:27:20 UTC
Well, I figure it out myself quite some time ago. But when I tried to
play music CD using ide-scsi computer hanged dead (or may be X hanged dead -
it was a home computer and I could not try to telnet to it; neither
Ctrl-Alt-Backspace nor Ctrl-Alt-F1, etc are worked), but CD played fine :).

I am not picky, I can do loading modules by hand, so I did not persue
the issue further (but issue is there).




Note You need to log in before you can comment on or make changes to this bug.