Bug 433809 - subversion failing selftests on ia64
subversion failing selftests on ia64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Doug Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-02-21 10:53 EST by Doug Chapman
Modified: 2008-02-24 23:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 23:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-02-21 10:53:00 EST
Description of problem:

This will be assigned to someone in the fedora-ia64 team for more triage since
we don't have installable rawhide-ia64 trees yet.

Subversion failing on ia64.  I will investigate more but it appears python is
not getting pulled in to the mock build.

From the build.log:

ENTER do("bash --login -c 'rpmbuild -bs --target ia64 --nodeps
//builddir/build/SPECS/subversion.spec'",
'/var/lib/mock/dist-f9-build-2547-758/root/', 0, True, 0, <mock.uid.uidManager
object at 0x200000000530a090>, 100, 103, None,
logger=<mock.trace_decorator.getLog object at 0x200000000530a750>)
run cmd timeout(0): bash --login -c 'rpmbuild -bs --target ia64 --nodeps
//builddir/build/SPECS/subversion.spec'
/etc/profile: line 38: /bin/hostname: No such file or directory
cat: /usr/include/httpd/.mmn: No such file or directory
sh: ruby: command not found
sh: /usr/bin/python: No such file or directory
sh: /usr/bin/python: No such file or directory
sh: /usr/bin/python: No such file or directory
sh: /usr/bin/python: No such file or directory

Then, after the build of subversion itself many (but oddly not all) tests
written in python fail:


Running all tests in translate-test...success
Running all tests in utf-test...success
Running all tests in target-test.py...success
Running all tests in getopt_tests.py...success
Running all tests in basic_tests.py...FAILURE
Running all tests in commit_tests.py...FAILURE
Running all tests in update_tests.py...FAILURE
Running all tests in switch_tests.py...FAILURE
Running all tests in prop_tests.py...FAILURE


Full build log can be found at:
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=13487&name=build.log


Version-Release number of selected component (if applicable):
subversion-1.4.6-5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-02-21 14:01:07 EST
It appears the "sh: /usr/bin/python: No such file or directory" messages are
unrelated.  I chedked on an x86_64 koji build log and it shows those same errors
but that build passed.  those are just seen when doing the rpmbuild -bs, not
when doing the actual build of the binary rpm.

So now it is just a matter of trying to figure out why many of the tests are
failing on ia64.
Comment 2 Zhan, Yi 2008-02-22 04:57:44 EST
I tried to build the package on my box using mock and the ia64 rawhide bits,
excepting one package buildsys-build, which we used to create the root-cache in
F8-cycle. But I was unable to reproduce this bug. The package just built
cleanly. I think it might be helpful to build it on other build servers again to
verify the error.  
Comment 3 Doug Chapman 2008-02-24 23:59:12 EST
subversion-1.4.6-5 has now built cleanly on our koji server.  Odd, must have
been a glitch on the build server I guess?

Note You need to log in before you can comment on or make changes to this bug.