Bug 433812 - klibido doesn't compile anymore on rawhide due to KDE4 and gcc 4.3
klibido doesn't compile anymore on rawhide due to KDE4 and gcc 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: klibido (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Francois Aucamp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 10:55 EST by Erik van Pienbroek
Modified: 2008-02-22 05:01 EST (History)
0 users

See Also:
Fixed In Version: 0_2_5-10_fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 05:00:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GCC 4.3 compilation fix (284 bytes, patch)
2008-02-21 10:55 EST, Erik van Pienbroek
no flags Details | Diff

  None (edit)
Description Erik van Pienbroek 2008-02-21 10:55:13 EST
Recently KDE4 and gcc 4.3 have been introduced in rawhide. Due to the
introduction of these two packages the compilation of klibido fails.

First off all, there is a BuildRequires: kdelibs-devel in the .spec file, this
needs to be changed to kdelibs3-devel, as kdelibs-devel now points to kdelibs 4
instead of kdelibs 3.

Second, the compilation fails due to more strictness in gcc 4.3. Attached patch
solves the compilation problem.
Comment 1 Erik van Pienbroek 2008-02-21 10:55:13 EST
Created attachment 295523 [details]
GCC 4.3 compilation fix
Comment 2 Francois Aucamp 2008-02-22 02:45:46 EST
(In reply to comment #1)
> Created an attachment (id=295523) [edit]
> GCC 4.3 compilation fix
> 

Thanks for this patch. :-) I actually fixed the build dependencies in CVS and
attempted a scratch build which didn't work out well due to the gcc 4.3 mass
rebuild strain on koji; will do so just now.
Comment 3 Francois Aucamp 2008-02-22 05:00:33 EST
Koji build succeeded:
http://koji.fedoraproject.org/koji/taskinfo?taskID=460496
Closing bug.

Note You need to log in before you can comment on or make changes to this bug.