Bug 433813 - postgresql failing make check on ia64
postgresql failing make check on ia64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Doug Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-02-21 10:58 EST by Doug Chapman
Modified: 2008-03-05 17:39 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 17:39:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-02-21 10:58:11 EST
Description of problem:

This will be assigned to someone on the fedora-ia64 team since we do not yet
have ia64 rawhide builds currently nor do many people have access to ia64 hardware.

postgresql failing in "make check" on ia64:

+ make MAX_CONNECTIONS=5 check
make -C ../../../src/port all
make[1]: Entering directory `/builddir/build/BUILD/postgresql-8.3.0/src/port'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/builddir/build/BUILD/postgresql-8.3.0/src/port'
make -C ../../../contrib/spi refint.so autoinc.so
make[1]: Entering directory `/builddir/build/BUILD/postgresql-8.3.0/contrib/spi'
make[1]: `refint.so' is up to date.
make[1]: `autoinc.so' is up to date.
make[1]: Leaving directory `/builddir/build/BUILD/postgresql-8.3.0/contrib/spi'
rm -rf ./testtablespace
mkdir ./testtablespace
./pg_regress --temp-install=./tmp_check --top-builddir=../../..
--srcdir=/builddir/build/BUILD/postgresql-8.3.0/src/test/regress
--temp-port=55432 --schedule=./parallel_schedule --multibyte=SQL_ASCII
--load-language=plpgsql  --max-connections=5  
============== creating temporary installation        ==============
============== initializing database system           ==============

pg_regress: initdb failed
Examine ./log/initdb.log for the reason.
Command was:
"/builddir/build/BUILD/postgresql-8.3.0/src/test/regress/./tmp_check/install//usr/bin/initdb"
-D "/builddir/build/BUILD/postgresql-8.3.0/src/test/regress/./tmp_check/data" -L
"/builddir/build/BUILD/postgresql-8.3.0/src/test/regress/./tmp_check/install//usr/share/pgsql"
--noclean > "./log/initdb.log" 2>&1
make: *** [check] Error 2


Full build log can be found at:
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=13222&name=build.log


Version-Release number of selected component (if applicable):
postgresql-8.3.0-2.fc9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-03-05 17:39:35 EST
appears to be working happily now

closing

- Doug

Note You need to log in before you can comment on or make changes to this bug.