Bug 433834 - circular loop in modules: chainiv.ko needs crypto_blkcipher.ko which needs chainiv.ko again!
circular loop in modules: chainiv.ko needs crypto_blkcipher.ko which needs ch...
Status: CLOSED DUPLICATE of bug 432813
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 12:12 EST by Tom London
Modified: 2008-02-22 11:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 11:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-02-21 12:12:35 EST
Description of problem:

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.25-0.61.rc2.git4.fc9 #1 SMP Thu Feb 21 01:59:58
EST 2008 i686 i686 i386 GNU/Linux
[root@localhost ~]# 

[root@localhost ~]# depmod -ae
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/drivers/crypto/hifn_795x.ko
ignored, due to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/drivers/crypto/geode-aes.ko
ignored, due to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/drivers/crypto/padlock-aes.ko
ignored, due to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/drivers/md/dm-crypt.ko ignored, due
to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/arch/x86/crypto/salsa20-i586.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/eseqiv.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/xts.ko
ignored, due to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/crypto_blkcipher.ko ignored,
due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/pcbc.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/seqiv.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/lrw.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/ecb.ko
ignored, due to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/salsa20_generic.ko ignored,
due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/ctr.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/ccm.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/authenc.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/cbc.ko
ignored, due to loop
WARNING: Module
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/crypto_null.ko ignored, due
to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/gcm.ko
ignored, due to loop
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/tcrypt.ko
ignored, due to loop
WARNING: Loop detected:
/lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/chainiv.ko needs
crypto_blkcipher.ko which needs chainiv.ko again!
WARNING: Module /lib/modules/2.6.25-0.61.rc2.git4.fc9/kernel/crypto/chainiv.ko
ignored, due to loop
[root@localhost ~]# 


Version-Release number of selected component (if applicable):
kernel-2.6.25-0.61.rc2.git4.fc9.i686

How reproducible:
every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-02-21 21:12:13 EST
Works for me with kernel-2.6.25-0.64.rc2.git5.fc9.i686
Comment 2 Charles R. Anderson 2008-02-22 11:34:29 EST

*** This bug has been marked as a duplicate of 432813 ***

Note You need to log in before you can comment on or make changes to this bug.