Bug 433836 - perl RPM needs Provides/Obsoletes for perl-File-Temp
Summary: perl RPM needs Provides/Obsoletes for perl-File-Temp
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: 8
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-21 17:22 UTC by Bill McGonigle
Modified: 2008-03-07 19:52 UTC (History)
4 users (show)

Fixed In Version: 5.8.8-36.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 19:52:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
perl.spec patch for perl-File-Temp Provides/Obsoletes (1.09 KB, application/octet-stream)
2008-02-21 17:22 UTC, Bill McGonigle
no flags Details

Description Bill McGonigle 2008-02-21 17:22:44 UTC
perl now includes File::Temp as part of the standard distribution.  Before that,
it was commonly used, so many 3rd-party packages required File::Temp, and good
little RPM-lovers distributed perl-File-Temp.

This led to common RPM's, such as perl-MIME-Tools, requiring perl(File::Temp).

Now that File::Temp is part of perl, yum will bail with conflicts since the
files conflict, e.g.:
Error: Transaction Check Error:
  file /usr/share/man/man3/File::Temp.3pm.gz from install of
perl-5.8.8-32.fc8.i386 conflicts with file from package
perl-File-Temp-0.19-1.fc8.rf.noarch

which is as it should be.

To solve this cleanly, perl needs to declare that it now has File::Temp.  I've
got a simple patch to the .spec I'll attach.  Please sanity-check it.

The goal here is to get yum working again for folks who use things like MailScanner.

Comment 1 Bill McGonigle 2008-02-21 17:22:44 UTC
Created attachment 295542 [details]
perl.spec patch for perl-File-Temp Provides/Obsoletes

Comment 2 Marcela Mašláňová 2008-02-22 08:24:12 UTC
Thank you for a patch, it will be i next update into F-8.

Comment 3 Stepan Kasal 2008-02-22 12:39:30 UTC
We shall not obsolete newer packages, so I changed that to

Provides: perl-File-Temp = 0.16
Obsoletes: perl-File-Temp < 0.16
Conflicts: perl-File-Temp

I also commited this to rawhide, to fix the problem for Fedora 9.

Comment 4 Bill McGonigle 2008-02-25 17:30:23 UTC
Thanks for the changes and the commit, Stephan.


Comment 5 Fedora Update System 2008-02-29 15:25:52 UTC
perl-5.8.8-35.fc8 has been submitted as an update for Fedora 8

Comment 6 Fedora Update System 2008-03-01 09:27:50 UTC
perl-5.8.8-35.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2164

Comment 7 Fedora Update System 2008-03-07 19:52:14 UTC
perl-5.8.8-36.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.