Bug 433848 - kudzu segfault with pv_ops Xen kernel
kudzu segfault with pv_ops Xen kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker PvOpsTracker
  Show dependency treegraph
 
Reported: 2008-02-21 13:44 EST by Mark McLoughlin
Modified: 2014-03-16 23:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.83-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 23:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-02-21 13:44:28 EST
With a Xen guest on rawhide using this pv_ops based kernel:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=455742

we get this segault in kudzu:

  Program received signal SIGSEGV, Segmentation fault.
  0x080575d9 in outb (value=0 '\0', port=992) at /usr/include/sys/io.h:99
  99        __asm__ __volatile__ ("outb %b0,%w1": :"a" (value), "Nd" (port));
  (gdb) bt
  #0  0x080575d9 in outb (value=0 '\0', port=992) at /usr/include/sys/io.h:99
  #1  0x0805759a in i365_get (sock=0, reg=0) at misc.c:79
  #2  0x080582d7 in miscProbe (probeClass=CLASS_UNSPEC, probeFlags=1, 
      devlist=0x808e2f0) at misc.c:314
  #3  0x0804fbf4 in probeDevices (probeClass=CLASS_UNSPEC, probeBus=-9, 
      probeFlags=1) at kudzu.c:878
  #4  0x0804c731 in main (argc=1, argv=0xbfd08384) at hwconf.c:839

notting's comment on this a while back was:

    <notting>       oh that's right. the code probing for ancient pre-cardbus
pcmcia controllers
    <notting>       hm, that can probably be taken out ;)
    <notting>       especially because we build them in
Comment 1 Bill Nottingham 2008-02-21 13:55:09 EST
Will be solved one way or another.
Comment 2 Bill Nottingham 2008-03-10 23:50:27 EDT
Fixed in 1.2.83-3.

Note You need to log in before you can comment on or make changes to this bug.