Bug 433890 - openser places libs in /usr/lib64 on ia64, should be /usr/lib
openser places libs in /usr/lib64 on ia64, should be /usr/lib
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openser (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-02-21 17:55 EST by Doug Chapman
Modified: 2008-02-23 13:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-23 13:57:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spcfile patch to define LIBDIR (650 bytes, patch)
2008-02-22 18:21 EST, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-02-21 17:55:28 EST
Description of problem:

On ia64 we don't support both 32 and 64 bit binaries like x86_64 and therefore
there is no /usr/lib64.  openser tries to put things in /usr/lib64 but then
fails to package it because it the looks in /usr/lib.  This breaks the build on
ia64.

build log showing the errors:

http://ia64.koji.fedoraproject.org/koji/getfile?taskID=14457&name=build.log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jan ONDREJ 2008-02-22 17:55:25 EST
This may help to fix this bug, when added to make commands (in build and install
sections):

LIBDIR=%{_lib}

This overwrites detection in openser's Makefile.defs.

Can anybody confirm this?

Code from Makefile.defs:
# ARCH is a little bit updated uname -m
ARCH_B= $(shell echo $(ARCH) | sed -e 's/.*64.*/64b/')                          
ifeq ($(ARCH_B),64b)                                                            
        LIBDIR ?= lib64                                                         
else                                                                            
        LIBDIR ?= lib                                                           
        # assume 32b - it is not really used further                            
        ARCH_B=32b                                                              
endif                                                                           
Comment 2 Doug Chapman 2008-02-22 18:21:36 EST
Created attachment 295687 [details]
spcfile patch to define LIBDIR

thanks, the LIBDIR suggestion does fix the issue.  Appears to only be needed in
the %install section.
Comment 3 Jan ONDREJ 2008-02-23 03:50:51 EST
Fixed in devel: openser-1.3.0-9

How I can rebuild package for ia64? Does it build automatically?
Comment 5 Doug Chapman 2008-02-23 13:50:19 EST
(In reply to comment #3)
> Fixed in devel: openser-1.3.0-9
> 
> How I can rebuild package for ia64? Does it build automatically?
> 

Not yet but hopefully soon.  Our ia64 koji server is at
ia64.koji.fedoraproject.org.  I will kick off a build there now.

- Doug
Comment 6 Doug Chapman 2008-02-23 13:56:50 EST
Actually it appears this did get built last night automatically (I have a hacked
up script that looks for jobs on the main koji server and resubmits them to ours).

Looks like it built cleanly, thanks!

http://ia64.koji.fedoraproject.org/koji/buildinfo?buildID=8015

Note You need to log in before you can comment on or make changes to this bug.