Bug 433910 - eclipse-setools missing setools.linux.ia64/build.properties
eclipse-setools missing setools.linux.ia64/build.properties
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-setools (Show other bugs)
9
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-02-21 21:49 EST by Doug Chapman
Modified: 2009-01-27 11:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 11:00:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-02-21 21:49:39 EST
Description of problem:

This still needs some triage which the fedora-ia64 team will provide.

eclipse-setools fails to build on ia64:

+ install -p -m644
/builddir/build/BUILD/eclipse-setools/setools.linux.ia64/build.properties
/var/tmp/eclipse-setools-3.3.2.3-1.fc9-Ovt2ZV/usr/lib/eclipse/plugins/com.tresys.setools.linux.ia64_
install: cannot stat
`/builddir/build/BUILD/eclipse-setools/setools.linux.ia64/build.properties': No
such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.90976 (%install)

full build log:
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=15717&name=build.log


Version-Release number of selected component (if applicable):
eclipse-setools-3.3.2.3-1.fc9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zhan, Yi 2008-02-22 04:30:17 EST
Seems that the package eclipse-setools does not support ia64 currently. There
are  setools.linux.x86(x86_64, ppc, ppc64) in the source dir but no
setools.linux.ia64 exists. 

Copy over selinux.linux.pcc64 and replace all the "ppc64" to "ia64" could get
the package built. But I have no idea if anything else should be done to get the
package actually support ia64 platform. 
Comment 2 Zhan, Yi 2008-02-22 05:10:54 EST
Since the package was written in java, I'm kinder hoping this could work.
Comment 3 Doug Chapman 2008-02-22 09:16:02 EST
Yi,

I think your suggestion in comment #1 is correct.  That is basically what I
needed to do in order to get the base eclipse package to build as well on ia64.

- Doug
Comment 4 Bug Zapper 2008-05-14 01:19:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Doug Chapman 2009-01-27 11:00:38 EST
We won't be able to do anything with this until there are new builds of Fedora on ia64.  Closing but will open a fresh one if this is still found to be an issue once builds begin again.

Note You need to log in before you can comment on or make changes to this bug.