Bug 433917 - arrow keys broke under gnome
arrow keys broke under gnome
Status: CLOSED DUPLICATE of bug 434669
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 23:12 EST by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 11:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (21.63 KB, text/plain)
2008-02-22 01:20 EST, Bill Nottingham
no flags Details
X conf (712 bytes, text/plain)
2008-02-22 01:21 EST, Bill Nottingham
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 14584 None None None Never

  None (edit)
Description Bill Nottingham 2008-02-21 23:12:40 EST
Description of problem:

Arrow keys are now broken under gnome for me, using a standard 105/US layout.

Up-arrow triggers the screenshooter (!?). Right arrow shows now events.
Left-arrow yields keycode 113, keysym 0xfe08, ISO_Next_Group. Down-arrow yields
keycode 116 (keysym 0xffec, Super_R)

I realize this could be one of about 1000 things that broke this.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.1-0.22.20080221.fc9.x86_64
xorg-x11-drv-keyboard-1.2.2-3.fc9.x86_64
control-center-2.21.90-10.fc9.x86_64
libxklavier-3.3-1.fc8.x86_64
libxklavier-3.4-1.fc9.x86_64
Comment 1 Bill Nottingham 2008-02-22 00:35:09 EST
CTRL-ALT-{backspace,F1,F2,etc.} are also broken, even on the GDM login screen.
Comment 2 Bill Nottingham 2008-02-22 01:20:57 EST
Created attachment 295591 [details]
X log

In the chance that this is a X bug, here's the log.
Comment 3 Bill Nottingham 2008-02-22 01:21:33 EST
Created attachment 295592 [details]
X conf

In the case that this is a X bug, here's the conf file.
Comment 4 Bill Nottingham 2008-02-22 01:30:55 EST
Assigning to the X server under the 'that's what actually changed recently'
methodology.
Comment 5 Matěj Cepl 2008-02-22 06:31:49 EST
Reassigning to Kristian under the 'that's most likely broken' methodology (and
it has severely changed recently as well).
Comment 6 Bill Nottingham 2008-02-22 14:12:14 EST
Reassinging per #desktop discussion.

CTRL-ALT-{backspace,F1,F2} is fd.o bug 14584. Patch in the bug. The arrow keys:

- Old X server defaults to pc105
- New X server defaults to evdev, even if pc105 is in xorg.conf
- If you have a saved pc105 xkb config in GNOME, GNOME attempts to apply it on
top of the evdev config.
- Bad things happen.
Comment 7 Bill Nottingham 2008-02-25 11:47:36 EST

*** This bug has been marked as a duplicate of 434669 ***

Note You need to log in before you can comment on or make changes to this bug.