Bug 433934 - Failed to start the X Server
Failed to start the X Server
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 02:57 EST by Y.C. Chen
Modified: 2015-01-14 18:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf and Xorg.0.log (7.24 KB, application/x-gzip)
2008-02-22 02:57 EST, Y.C. Chen
no flags Details
xorg.conf from the attachment 295597 (570 bytes, text/plain)
2008-02-22 06:18 EST, Matěj Cepl
no flags Details
Xorg.0.log from the attachment 295597 (42.35 KB, text/plain)
2008-02-22 06:18 EST, Matěj Cepl
no flags Details

  None (edit)
Description Y.C. Chen 2008-02-22 02:57:28 EST
Description of problem:
1. Use ASPEED AST2000 Adapter to install FC8.
2. It will show following message while system boot:
Failed to start X Server (your graphical interface). It is likely that it is 
not set up correctly. .....

Additional info:
1. If run startx in text console mode, then it can start X properly.So, if it's 
the issues of driver issue or X config, it should still failed if run startx in 
cosole mode
Comment 1 Y.C. Chen 2008-02-22 02:57:28 EST
Created attachment 295597 [details]
xorg.conf and Xorg.0.log
Comment 2 Matěj Cepl 2008-02-22 06:18:24 EST
Created attachment 295615 [details]
xorg.conf from the attachment 295597 [details]
Comment 3 Matěj Cepl 2008-02-22 06:18:33 EST
Created attachment 295616 [details]
Xorg.0.log from the attachment 295597 [details]
Comment 4 Y.C. Chen 2008-02-24 21:11:21 EST
Hi,
If the owner assignment is not correct, please help to re-assignment to the 
right one.
Thanks,
Y.C. Chen
Comment 5 Matěj Cepl 2008-02-25 12:07:44 EST
Ajax, this might be the general Xserver breakage I observe on my office Radeon
computer as well.
Comment 6 Y.C. Chen 2008-02-27 00:46:34 EST
Hi,
I had tried ASPEED AST2000, ATI RageXL, S3 Trio64, and only AST2000 has this 
issue. I just don't understandard if it's the issue of AST2000 driver, then it 
should be failure also if run startx in text console mode.
Besides I had tried AST2000 on FC7, FC8 test1, Suse 10.3 and Ubuntu 7.10, they 
are all use xorg 7.2 and no such issue. 
Does anyone have any suggestion?

Y.C. Chen
Comment 7 Adam Jackson 2008-03-04 15:23:55 EST
That X log shows a successful startup.  Does running "X" on its own give you a
working display?
Comment 8 Y.C. Chen 2008-03-05 00:24:14 EST
Hi,
Yes!
What should I do for further check?

Y.C. Chen
Comment 9 Adam Jackson 2008-03-12 17:00:25 EDT
Well, whatever this is, it's not an X problem.  Since you say 'startx' works
too, I'm blaming gdm here.
Comment 10 Y.C. Chen 2008-04-04 03:53:13 EDT
Hi,
Need us to provide more information? If anyone wants us to provide more 
information or do some test, then just please inform to us.

Regards,

Y.C. Chen
Comment 11 Bug Zapper 2008-11-26 04:54:54 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2009-01-09 02:40:36 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.