Bug 433948 - Duplicate alias in rt73usb and rt2500usb modules
Summary: Duplicate alias in rt73usb and rt2500usb modules
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-22 10:22 UTC by Piergiorgio Sartor
Modified: 2008-02-22 15:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 15:03:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Piergiorgio Sartor 2008-02-22 10:22:32 UTC
Description of problem:
First of all, I would apologize in advance if this is not a bug or if it's
duplicated one.
The issue, which could be somehow found also searching around in internet, is
that both modules have same alias for some devices.
There are suggestions around to blacklist one or the other module, in order to
have the proper one loaded.
I could imagine the aliases should be always unique, but I'm not sure.

Version-Release number of selected component (if applicable):
kernel-2.6.23.15-137.fc8

How reproducible:
Well, always, in this kernel.

Steps to Reproduce:
1.
From root shell:
( modinfo rt73usb; modinfo rt2500usb ) | grep alias | sort | uniq -d

Actual results:
alias:          usb:v050Dp7050d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp705Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v148Fp2573d*dc*dsc*dp*ic*isc*ip*

Expected results:
I guess nothing should appear, as per, for example, the pci ralink modules.

Comment 1 John W. Linville 2008-02-22 15:03:16 UTC
Well, I wish it were that simple.  Unfortunately some manufacturers have used 
the same USB ID for devices with different hardware underneath.  At present, 
listing the ID is both possible drivers is the best alternative we have.  I'm 
sorry.


Note You need to log in before you can comment on or make changes to this bug.