Bug 433969 - mbuffer failed massrebuild attempt for GCC 4.3
mbuffer failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mbuffer (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
:
: 440836 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 07:51 EST by Jesse Keating
Modified: 2013-01-09 21:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 07:51:06 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436007
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-22 09:19:28 EST
mbuffer.c:33:3: warning: #warning Your sendfile implementation does not seem to
support sending from buffers - disabling sendfile support.
mbuffer.c: In function 'debugmsg':
mbuffer.c:118: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'infomsg':
mbuffer.c:135: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'warningmsg':
mbuffer.c:150: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'errormsg':
mbuffer.c:166: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'fatal':
mbuffer.c:182: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'summary':
mbuffer.c:270: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'statusThread':
mbuffer.c:377: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
In function 'open',
    inlined from 'main' at mbuffer.c:1340:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared
with attribute error: open with O_CREAT in second argument needs 3
argumentsmbuffer.c:33:3: warning: #warning Your sendfile implementation does not
seem to support sending from buffers - disabling sendfile support.
mbuffer.c: In function 'debugmsg':
mbuffer.c:118: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'infomsg':
mbuffer.c:135: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'warningmsg':
mbuffer.c:150: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'errormsg':
mbuffer.c:166: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'fatal':
mbuffer.c:182: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'summary':
mbuffer.c:270: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
mbuffer.c: In function 'statusThread':
mbuffer.c:377: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
In function 'open',
    inlined from 'main' at mbuffer.c:1340:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared
with attribute error: open with O_CREAT in second argument needs 3 arguments
Comment 2 Bug Zapper 2008-05-14 01:21:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 13:14:03 EDT
*** Bug 440836 has been marked as a duplicate of this bug. ***
Comment 4 Matt Domsch 2008-07-08 00:37:43 EDT
builds as of 2008-07-03, version 20080507-2.fc10.

Note You need to log in before you can comment on or make changes to this bug.