Bug 433987 - mysql-gui-tools failed massrebuild attempt for GCC 4.3
mysql-gui-tools failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mysql-gui-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 07:53 EST by Jesse Keating
Modified: 2013-01-09 21:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 14:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for GCC 4.3 port (1.76 KB, patch)
2008-04-06 04:55 EDT, Denis Leroy
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 07:53:02 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436462
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-22 14:44:42 EST
MGFileBrowserList.cc: In constructor 'MGFileBrowserList::MGFileBrowserList(const
Glib::ustring&, const std::string&, bool)':
MGFileBrowserList.cc:36: error: 'strerror' was not declared in this scope
MGFileBrowserList.cc: In member function 'bool MGFileBrowserList::rename(const
std::string&, const std::string&)':
MGFileBrowserList.cc:176: error: 'strerror' was not declared in this scope
MGFileBrowserList.cc: In member function 'bool MGFileBrowserList::remove(const
std::string&)':
MGFileBrowserList.cc:190: error: 'strerror' was not declared in this scope
make[3]: *** [MGFileBrowserList.o] Error 1
make[3]: *** Waiting for unfinished jobs....
MGHMeterGraphPlotter.cc: In member function 'Glib::ustring
MGHMeterGraphPlotter::format_value(double)':
MGHMeterGraphPlotter.cc:71: error: 'strcat' was not declared in this scope
Comment 2 Denis Leroy 2008-04-06 04:55:55 EDT
Created attachment 301416 [details]
Patch for GCC 4.3 port

Here's a patch for the GCC 4.3 issues.
Comment 3 Bug Zapper 2008-05-14 01:21:57 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Pavel Alexeev 2008-08-04 06:56:54 EDT
It seems not enough. I'm additionally add -D_GNU_SOURCE in Makefile.in

Please see in my repository src.rpm: http://hubbitus.net.ru/rpm/Fedora9/mysql-gui-tools/mysql-gui-tools-5.0r12-1.fc9.Hu.10.src.rpm (mysql-gui-tools-5.0r12.GCC43-glibc28.patch in them)
Comment 5 Dennis Gilmore 2008-09-10 14:29:39 EDT
i have gotten mysql-gui-tools building with gcc-4.3.0 in Fedora-9  but its failing with 4.3.0   the ancient embeded gtksourceview in mysql-query-browser is the culprit.  it has two functions in added.  Ive started looking at what it will take to get them upstream.  or work out how to work arround them.

though MySQL has not released a new verison in quite some time.  and they dont have public RCS to see if there is even work happening on it.
Comment 6 Pavel Alexeev 2008-09-15 12:59:50 EDT
Yes, I'm build it for rawhide!

And no, not new gcc version is cause, but is new version of GTK!

Please see scratch build http://koji.fedoraproject.org/koji/taskinfo?taskID=826162 and last patch in src.rpm package for this purpose!
Comment 7 Dennis Gilmore 2008-09-15 14:47:05 EDT
mysql-gui-tools-5.0r12-9.fc10 icludes the patch.  thanks Pavel.  I have question for you also.  were do the otehr source files you include come from?  and what is their purpose.  If you want to co-maintain mysql-gui-tools please apply in pkgdb
Comment 8 Pavel Alexeev 2008-09-16 02:55:31 EDT
(In reply to comment #7)
> I have
> question for you also.  were do the otehr source files you include come from?
Hmmm. The history of this sources started long ago and most of them come from original upstream src.rpm ( http://dev.mysql.com/get/Downloads/MySQLGUITools/mysql-gui-tools-5.0r12-1fc5.src.rpm/from/pick#mirrors )

Few patches was googled, but few is my patches. 	
I try to pick that information as possible on the changelog.

> If you want to co-maintain mysql-gui-tools please apply in pkgdb
Many thanks for the offer, but I do not know how to do it.
Comment 9 Pavel Alexeev 2008-09-28 11:14:37 EDT
Hello, Denis.

What you think about failed build in rawhide rebuild 2008-09-23?

http://www.linux-archive.org/fedora-development/165387-fedora-rawhide-rebuild-mock-status-2008-09-23-i386.html

It is failed to build on mysql-gui-tools-5.0r12-8.fc9.src.rpm why? Do you push updated mysql-gui-tools-5.0r12-9.fc10 into CVS?
Comment 10 Dennis Gilmore 2008-09-28 12:10:17 EDT
the recent build failed because an old srpm was used. http://koji.fedoraproject.org/koji/buildinfo?buildID=63153  is the koji build for mysql-gui-tools-5.0r12-9.fc10  once beta freeze is over it will land in rawhide.   I don't think the fixes that its introduce need to make it get included in the beta.   the next attempt at the mass rebuild should be fine.
Comment 11 Pavel Alexeev 2008-09-29 08:34:14 EDT
However you commit changes in rawhide and we can only wait?

And as I can understand beta freeze do not sense to bugfixes t is only prohibit new futures??

>I don't think the fixes that its introduce need to make it get
>included in the beta.
Why?? You are think what mysql-guil-tools do not need in Fedora 10???
Comment 12 Dennis Gilmore 2008-09-29 10:23:24 EDT
(In reply to comment #11)
> However you commit changes in rawhide and we can only wait?
todays rawhide report

mysql-gui-tools-5.0r12-9.fc10
-----------------------------
* Mon Sep 15 18:00:00 2008 Dennis Gilmore <dennis@ausil.us> - 5.0r12-9
- apply patch from Pavel Alexeev for gtk 
- bugzilla #433987

> And as I can understand beta freeze do not sense to bugfixes t is only prohibit
> new futures??
 
> >I don't think the fixes that its introduce need to make it get
> >included in the beta.
> Why?? You are think what mysql-guil-tools do not need in Fedora 10???

because its not fixing a bug that effects end user useability 
and it was released today in the unfrozen rawhide.  so it will be in F-10
Comment 13 Pavel Alexeev 2008-09-29 17:35:08 EDT
Ok, thanks for the explanation.

Note You need to log in before you can comment on or make changes to this bug.