Bug 433988 - oooqs2 failed massrebuild attempt for GCC 4.3
oooqs2 failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oooqs2 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Reopened
: 449600 (view as bug list)
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 07:53 EST by Jesse Keating
Modified: 2013-01-09 21:47 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.0-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-03 03:14:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 07:53:08 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436486
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-22 14:45:43 EST
+ . /etc/profile.d/qt.sh
/var/tmp/rpm-tmp.52781: line 29: /etc/profile.d/qt.sh: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.52781 (%build)
Comment 2 Christopher Aillon 2008-03-27 17:51:22 EDT
Fixed the above by fixing the BuildRequires to use kdelibs3-devel

But the build still fails:

http://koji.fedoraproject.org/koji/getfile?taskID=535030&name=build.log
oooqs2detector.cpp: In static member function 'static QString
OOoQs2Detector::detectBinary()':
oooqs2detector.cpp:68: error: 'getenv' was not declared in this scope

Needs to #include <cstdlib> for this.  Unsure if other things remain...
Comment 3 Rex Dieter 2008-04-02 22:01:39 EDT
looking
Comment 4 Rex Dieter 2008-04-02 22:07:19 EDT
fixed in rawhide.
Comment 5 Rex Dieter 2008-04-02 22:40:04 EDT
hrm, build succeeded locally, but not in koji, reopening.
Comment 6 Bug Zapper 2008-05-14 01:22:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matt Domsch 2008-07-03 12:05:38 EDT
*** Bug 449600 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Kofler 2008-08-03 03:14:14 EDT
Just resent 1.0-5 to Koji and it built:
http://koji.fedoraproject.org/koji/taskinfo?taskID=755085

Note You need to log in before you can comment on or make changes to this bug.