This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 434012 - enblend failed massrebuild attempt for GCC 4.3
enblend failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enblend (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bruno Postle
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 07:55 EST by Jesse Keating
Modified: 2013-01-09 21:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 23:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gcc patches (806 bytes, text/x-patch)
2008-04-07 23:10 EDT, Jef Spaleta
no flags Details
New spec which uses the patches (3.39 KB, text/x-rpm-spec)
2008-04-07 23:12 EDT, Jef Spaleta
no flags Details

  None (edit)
Description Jesse Keating 2008-02-22 07:55:32 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436912
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-23 14:29:34 EST
gpu.cc: In function 'void checkGLErrors(int, char*)':
gpu.cc:70: error: 'exit' was not declared in this scope
gpu.cc: In function 'bool initGPU(int*, char**)':
gpu.cc:130: error: 'exit' was not declared in this scope
gpu.cc:149: error: 'exit' was not declared in this scope
gpu.cc:166: error: 'exit' was not declared in this scope
gpu.cc: In function 'bool configureGPUTextures(unsigned int, unsigned int)':
gpu.cc:191: warning: deprecated conversion from string constant to 'char*'
gpu.cc:200: warning: deprecated conversion from string constant to 'char*'
gpu.cc:209: warning: deprecated conversion from string constant to 'char*'
gpu.cc:225: error: 'exit' was not declared in this scope
Comment 2 Jef Spaleta 2008-02-27 02:34:03 EST
okay the gpu.cc error is easy to fix with #include <cstdlib> patch

But after getting that sorted.. im getting errors from vigra about an ambigious
overloaded abs function which I'm not sure what to do with.

I think it has to do with the abs definition in config.hxx in the vigra codebase.
I'm working on it.

-jef
Comment 3 Jef Spaleta 2008-02-27 03:01:26 EST
okay i'm giving up for this evening. I'm commit the small gcc43 patch which
fixes the initial error.

Bruno can you take a look at the vigra issue?

-jef
Comment 4 Jef Spaleta 2008-02-27 03:21:07 EST
Bruno i think there was a new pre-release of enblend-enfuse as of today. But I
can't figure out how to get it to build it.

-jef
Comment 5 Bruno Postle 2008-02-27 05:04:00 EST
I don't see the gpu.cc error in mock (strange), I did report the std::abs error
upstream, but there haven't been any enblend CVS commits since then:

http://sourceforge.net/tracker/index.php?func=detail&aid=1895675&group_id=123407&atid=696410.
Comment 6 Jef Spaleta 2008-02-27 16:18:26 EST
didn't see the gpu.cc errors in mock?  I did I ran a local build against
fedora-devel-i386 and built the committed patch based on my local testing.

But the abs overloading junkage I don't know how to fix...yet.

-jef
Comment 7 Jef Spaleta 2008-04-07 19:03:06 EDT
I got it building in mock for fedora-devel-i386.

I'm going to submit the patch and an updated spec file to cvs and do a koji
build in the next hour or so.

Cross your fingers.

-jef

Comment 8 Jef Spaleta 2008-04-07 23:10:43 EDT
Created attachment 301595 [details]
gcc patches
Comment 9 Jef Spaleta 2008-04-07 23:12:17 EDT
Created attachment 301596 [details]
New spec which uses the patches

ACLs prevent me from committing to the enblend devel branch.

But the patches and new spec work locally under mock.
Need to get this in to the build system before the freeze if we can!

-jef
Comment 10 Jesse Keating 2008-04-07 23:20:15 EDT
Submitted as http://koji.fedoraproject.org/koji/taskinfo?taskID=555956

Note You need to log in before you can comment on or make changes to this bug.