Bug 43402 - xmms and mpg123 on RH7.1 are have some problems...
xmms and mpg123 on RH7.1 are have some problems...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: esound (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-04 14:35 EDT by Kedar Patankar.
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 03:09:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kedar Patankar. 2001-06-04 14:35:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (WinNT; U ;Nav)

Description of problem:
I have a Duron 600MHz + AZ11e (KT133 chipset) motherboard, with onboard ac97 codec audio, an ati xpert 98 pci vide card and 64MB 
Ram. 
I find that in RH7.1, xmms and mpg123 both produce a chirpy audio output.

How reproducible:
Always

Steps to Reproduce:
1. Get the same hardware setup as I do. Duron600MHz, FIC AZ11e motherboard, onboard sound.
2. Just try playing any wav/mp3/ogg file.


Actual Results:  The output would be chirpy.


Expected Results:  The output should clean. w/o the chirp.

Additional info:

When I try freeamp on the same setup, it works flawlessly. Same with "dd if=raw_pcm_data.bin of=/dev/dsp bs=512 count=102400". Its only 
the 
xmms and mpg123 that seem to be broken.
Comment 1 Bill Nottingham 2001-06-05 00:17:04 EDT
If you use the OSS plugin for xmms instead of ESD, does it make any difference?
Comment 2 Need Real Name 2001-06-08 00:31:14 EDT
I too experienced audio distortion with xmms 1.2.4-13.  The distortion seemed 
to occur on MP3s that were sampled at 48KHz, the 44KHz MP3 files sound fine.  
It seems to be something with Release 13 of 1.2.4.  I downloaded 1.2.4-1 from 
the xmms website, and this resolved my issue.

This problem occured on two different machines both running 7.1, one with a 
Diamond MonsterSound MX300 (Aureal Vortex 2) and the other with a Creative 
Sound Blaster Live!  Installing 1.2.4-1 resolved the issue on both machines.

Gavin
Comment 3 Bill Nottingham 2001-06-08 11:34:39 EDT
Did you check to see output plugin you were using in both cases?
The two RPMs default to using different ones (ESD vs. OSS)...
Comment 4 Need Real Name 2001-06-08 12:34:29 EDT
No I did not.  I will upgrade to release 13 later this afternoon and try 
again.  I will let you know the results.

Gavin
Comment 5 Need Real Name 2001-06-08 12:51:25 EDT
Ok, I was a little curious myself.  I upgraded back to release 13 and it 
appears the OSS Driver 1.2.4 [libOSS.so] works fine.  When I switch to eSound 
Output Plugin 1.2.4 [libesdout.so] the sound is very distorted (metallic 
sounding).  Again, it is not on all MP3 files.  Seems to happen on 128 Kbps/48 
KHz.

Please let me know if you require further information.

Thanks,
Gavin
Comment 6 Bill Nottingham 2001-06-08 12:55:28 EDT
OK, so it appears esd is downsampling 48kHz to 44kHz, and doing it rather
badly.
Comment 7 Gilles CHAUVIN 2001-06-18 17:40:38 EDT
I tried mpg123 on the following hardware:
- Pentium 200MMX with SB AWE64 ISA PnP
- Pentium 100 with SB compatible soundcard
- Duron 750 (I don't remember the soundcard)
- Also try an old Pentium 75 TOSHIBA laptop (with OSS AudioDrive built-in 
soundchip) :)

I encounter the same problem with the 4 machines desbribed above. I don't know 
if this can help.
Comment 8 Kedar Patankar. 2001-06-19 13:06:39 EDT
Also xmms seems *very* sluggish on my Duron 600MHz+64MB+AZ11e box. I tried
changing the playback rate to 48khz and it started playing OK. But every 4-5
seconds the (analyser) display would freeze for 1-2 seconds. If I try to move
the xmms window around, then it gets stuck somewhere in between for 1-2 seconds.
Comment 9 Bill Nottingham 2001-06-19 16:27:54 EDT
In general, to fix this sort of behavior, switching to the OSS plugin
should work.

Assigning to esound; its resampling needs fixed, somehow.
Comment 10 David Balažic 2001-07-04 06:40:12 EDT
I have some similar experiences :

I have distorted sound when using esd based programs on a RH 7.1/i386 system.
It is like some noise is mixed with the sound.

play some.wav  -> OK
esdplay some.wav -> noise

some.wav is stereo 16 bit , 44100 kHz

Upgrading to kernel 2.4.3-12.i686 did not help.

But if I run the esd demon by hand and then while it is running I run esdplay,
then it plays without distortions. If I stop esd and play again
( in this case esdplay autospawns the esd server ) then it is again noisy.


Might be related to bug 37078

Hardware :
MSI K7T Pro2A motherboard ( KT133 + 686B )
Duron 700
256 MB ram
Software : Redhat Linux 7.1
Comment 11 Vidar Langseid 2001-08-23 03:09:18 EDT
I did too have similar problems with my ac97.
I bought (it is not expensive) the OSS driver from www.4front-tech.com. That
solved the problem for me. Now, esound works for me
 
Looks like a compatibilty issue between the OSS/Free driver and esound ?
Comment 12 Elliot Lee 2001-12-28 14:13:08 EST
esound just has issues, not planning to fix them anytime soon (since I happen to
be upstream esound non-maintainer, there's no hope from that area for now).

If someone is interested in working on a patch, I'd be happy to try to help.
Otherwise, the accepted solution seems to be using the OSS plugin for xmms
(which, given the hardware mixing capabilities of modern sound cards, would be
an increasingly good idea even if esound worked perfectly).

Note You need to log in before you can comment on or make changes to this bug.