Bug 434039 - xfce4-battery-plugin failed massrebuild attempt for GCC 4.3
xfce4-battery-plugin failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce4-battery-plugin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
http://bugzilla.xfce.org/show_bug.cgi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 07:58 EST by Jesse Keating
Modified: 2013-01-09 21:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 12:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 07:58:23 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=437732
Unknown exit code, check the failed task.
Comment 1 Jon Stanley 2008-02-23 16:17:14 EST
Couldn't build SRPM - missing patch:

rpmbuild --define "_sourcedir
/tmp/koji/tasks/439897/scmroot/rpms/xfce4-battery-plugin/devel" --define
"_specdir /tmp/koji/tasks/439897/scmroot/rpms/xfce4-battery-plugin/devel"
--define "_builddir
/tmp/koji/tasks/439897/scmroot/rpms/xfce4-battery-plugin/devel" --define
"_srcrpmdir /tmp/koji/tasks/439897/scmroot/rpms/xfce4-battery-plugin/devel"
--define "_rpmdir
/tmp/koji/tasks/439897/scmroot/rpms/xfce4-battery-plugin/devel" --define "dist
.fc9" --define "fedora 9" --define "dist .fc9" --define "fedora 9" --nodeps -bs
xfce4-battery-plugin.spec
error: File
/tmp/koji/tasks/439897/scmroot/rpms/xfce4-battery-plugin/devel/xfce4-battery-plugin-0.5.0-acpi.patch:
No such file or directory
Comment 2 Christoph Wickert 2008-02-24 05:53:12 EST
Sorry, I forgot to commit the patch, but the package fails to built with it too.
Contacted upstream for help, stay tuned.

Jon, please don't change the "assigned" field if you are not the assignie. As
long as the assignie hasn't looked at this, the bug is still new.
Comment 3 Jesse Keating 2008-02-24 09:36:23 EST
Christoph, please see https://fedoraproject.org/wiki/BugZappers, particularly:

https://fedoraproject.org/wiki/BugZappers/TakingAction and
https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow

This was discussed at great length on the fedora lists for a while, and plenty
of opportunity was given for feedback.
Comment 4 Christoph Wickert 2008-02-24 10:47:36 EST
To be honest I never heard of that before. I cannot find an announcement on
fedora-announce or devel-announce. A can't find a single mail about Bugzappers
on devel-list or the old maintainers list. And so can't google.
Comment 5 Jon Stanley 2008-02-25 10:41:48 EST
Christoph -

Sorry for any lack of communication, you're right that I did not submit anything
to devel-announce.  I apologize for that.  However, here's one of many threads
on devel-list about this (this one deals with the workflow specifically):

https://www.redhat.com/archives/fedora-devel-list/2008-January/msg01359.html

And if it won't build with the patch because of compiler problems, please remove
this bug from the gcc43rebuildfail tracker and add it to gcc43errors - that way
Jakub Jelinek can have a look at it if needed.
Comment 6 Jon Stanley 2008-02-25 17:29:13 EST
Thanks for mentioning that I didn't send this to devel-announce - really.  It's
been sent now:

https://www.redhat.com/archives/fedora-devel-announce/2008-February/msg00019.html
Comment 7 Christoph Wickert 2008-03-18 12:54:43 EDT
(In reply to comment #5)
> And if it won't build with the patch because of compiler problems, please remove
> this bug from the gcc43rebuildfail tracker and add it to gcc43errors - that way
> Jakub Jelinek can have a look at it if needed.

It's not related to gcc43 at all but to kernel 2.6.24, see
http://bugzilla.xfce.org/show_bug.cgi?id=3938 so I'm removing gcc43rebuildfail
tracker.

(In reply to comment #6)
> Thanks for mentioning that I didn't send this to devel-announce - really.

I have seen your mail. Thanks a lot for the clarification. I was under the
impression that ASSIGNED means "owner is working on this".
Comment 8 Christoph Wickert 2008-04-05 12:07:09 EDT
Fixed in Rawhide. CLOSING
Comment 9 Fedora Update System 2008-04-05 12:56:25 EDT
xfce4-battery-plugin-0.5.0-4.fc8 has been submitted as an update for Fedora 8

Note You need to log in before you can comment on or make changes to this bug.