Bug 43404 - Need to connect order parts together
Need to connect order parts together
Status: CLOSED DEFERRED
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cameron Prince
wbirkhea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-04 14:45 EDT by Jay Turner
Modified: 2015-01-07 18:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 20:43:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-06-04 14:45:41 EDT
Description of Problem:
Need some way to connect together the various orders which are created from
purchasing RHN subscriptions along with another product type.  Need to
change content on the receipt to message to the user that there might be
multiple order numbers created out of the one order they have a receipt for.

In addition, need to train the customer service people about what we are
doing with the orders.

Finally, we need to modify the order history page to message to the user
what sub orders go with which main orders.

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Cameron Prince 2001-06-07 20:43:43 EDT
The messaging has been added to the html receipt page to indicate multiple order
numbers.

As for considering sub-orders, the problem is the database doesn't consider them
sub-orders. Only Interchange does. So without adding a column to web_user_order
to store a master order number, we can't associate one order with another for
display on the order history page.

We will either need to allow the messaging on the receipt page to suffice, or
add the column to web_user_order to take care of the issue.
Comment 2 Jay Turner 2001-09-18 09:32:08 EDT
Deferring this as we did not launch Interchange.

Note You need to log in before you can comment on or make changes to this bug.