Bug 434055 - libnl failed massrebuild attempt for GCC 4.3
libnl failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-02-22 08:00 EST by Jesse Keating
Modified: 2013-01-09 21:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 14:31:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix build break (406 bytes, patch)
2008-02-22 09:39 EST, Neil Horman
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 08:00:06 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438074
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Neil Horman 2008-02-22 09:39:31 EST
Created attachment 295632 [details]
patch to fix build break

looks like the mass rebuild coincided with a glibc or kernel-headers update
that either moved the definition of ULONG_MAX to limits.h, or broke the include
chain so that whatever previously pulled in limits.h no longer does. This patch
fixes it for me in a scratch build against the f9-alpha build target
Comment 2 Dan Williams 2008-02-22 14:31:34 EST
Thanks Neil!  Rebuilt with your patch, libnl-1.1-3.fc9

Note You need to log in before you can comment on or make changes to this bug.