Bug 434076 - itpp failed massrebuild attempt for GCC 4.3
itpp failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: itpp (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
: 440939 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:02 EST by Jesse Keating
Modified: 2013-01-09 21:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 19:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 08:02:31 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438534
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-24 10:39:11 EST
some of the errors in x86_64 build.log:

In file included from ../../../itpp/base/vec.h:41,
                 from ../../../itpp/base/mat.h:471,
                 from ../../../itpp/base/algebra/inv.h:33,
                 from ../../../itpp/base/algebra/inv.cpp:40:
../../../itpp/base/copy_vector.h: In function 'void itpp::copy_vector(int, const
int*, int*)':
../../../itpp/base/copy_vector.h:54: error: 'memcpy' was not declared in this scope
../../../itpp/base/copy_vector.h: In function 'void itpp::copy_vector(int, const
short int*, short int*)':
../../../itpp/base/copy_vector.h:55: error: 'memcpy' was not declared in this scope
../../../itpp/base/copy_vector.h: In function 'void itpp::copy_vector(int, const
itpp::bin*, itpp::bin*)':
../../../itpp/base/copy_vector.h:56: error: 'memcpy' was not declared in this scope
../../../itpp/base/copy_vector.h: In function 'void itpp::copy_vector(int, const
float*, float*)':
../../../itpp/base/copy_vector.h:57: error: 'memcpy' was not declared in this scope
../../../itpp/base/copy_vector.h: In function 'void itpp::copy_vector(int, const
std::complex<float>*, std::complex<float>*)':
../../../itpp/base/copy_vector.h:58: error: 'memcpy' was not declared in this scope
Comment 2 Bug Zapper 2008-05-14 01:24:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 13:45:17 EDT
*** Bug 440939 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:12:08 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 5 manuel wolfshant 2008-09-14 19:02:16 EDT
I am not sure if anyone is still interested in this package, but I added a patch which fixes building in rawhide.
Comment 6 Ed Hill 2008-09-14 19:43:25 EDT
Thank you Manuel.  I've been meaning to update itpp but have been overcome
with work issues recently.

Note You need to log in before you can comment on or make changes to this bug.