Bug 434084 - kismet failed massrebuild attempt for GCC 4.3
kismet failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kismet (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
: 449499 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:03 EST by Jesse Keating
Modified: 2013-01-09 21:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:36:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix gcc 4.3 compilation problems (924 bytes, patch)
2008-02-22 10:19 EST, Erik van Pienbroek
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 08:03:23 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438645
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-22 09:29:59 EST
Errors x86_64 in build.log:

ringbuf.cc: In member function 'int RingBuffer::InsertData(uint8_t*, int)':
ringbuf.cc:60: error: 'memcpy' was not declared in this scope
ringbuf.cc:69: error: 'memcpy' was not declared in this scope
ringbuf.cc: In member function 'void RingBuffer::FetchPtr(uint8_t*, int, int*)':
ringbuf.cc:105: error: 'memcpy' was not declared in this scope
ringbuf.cc:110: error: 'memcpy' was not declared in this scope
ringbuf.cc:126: error: 'memcpy' was not declared in this scope
make: *** [ringbuf.o] Error 1
Comment 2 Erik van Pienbroek 2008-02-22 10:19:21 EST
Created attachment 295641 [details]
Patch to fix gcc 4.3 compilation problems

Attached patch fixes all the GCC 4.3 compilation problems
Comment 3 Bug Zapper 2008-05-14 01:25:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matt Domsch 2008-07-03 13:32:25 EDT
*** Bug 449499 has been marked as a duplicate of this bug. ***
Comment 5 Matt Domsch 2008-07-08 00:36:44 EDT
builds as of 2008-07-03, version 0.0.2008.05.R1-2.fc10.

Note You need to log in before you can comment on or make changes to this bug.