Bug 434089 - pekwm failed massrebuild attempt for GCC 4.3
pekwm failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pekwm (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Rice
Fedora Extras Quality Assurance
:
: 440883 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:04 EST by Jesse Keating
Modified: 2013-01-09 21:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 13:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 08:04:01 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438712
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-24 12:12:51 EST
In file included from ColorHandler.cc:8:
ColorHandler.hh: In member function 'bool ColorHandler::Entry::operator==(const
std::string&)':
ColorHandler.hh:33: error: 'strcasecmp' was not declared in this scope
ColorHandler.cc: In member function 'XColor* ColorHandler::getColor(const
std::string&)':
ColorHandler.cc:56: error: 'strcasecmp' was not declared in this scope
In file included from CfgParserSource.cc:14:
Util.hh: In function 'bool Util::isTrue(const std::string&)':
Util.hh:51: error: 'strncasecmp' was not declared in this scope
CfgParserSource.cc: In member function 'virtual bool
CfgParserSourceCommand::open()':
CfgParserSource.cc:102: error: 'exit' was not declared in this scope
make[2]: *** [ColorHandler.o] Error 1
Comment 2 Bug Zapper 2008-05-14 01:25:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 13:17:58 EDT
*** Bug 440883 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:25:13 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 5 Matt Domsch 2008-09-17 11:19:39 EDT
We can go 2 ways with this.

0.1.5 + fixes for the gcc 4.3 compile errors
or
0.1.7 which already compiles cleanly with gcc 4.3, but then someone needs to re-evaluate the Fedora-specific patches being applied in the spec file, in particular, the menu changes.

If those menu changes aren't critical, I'd say drop them and move on to 0.1.7.

Michael Rice - what say you as package owner?
Comment 6 Matt Domsch 2008-09-17 11:28:48 EDT
I went ahead and did the 0.1.5 + gcc 4.3 fixes, and am building it for rawhide.
http://koji.fedoraproject.org/koji/taskinfo?taskID=830427

But I'll leave this open, as I think it makes sense to upgrade to 0.1.7, but need the owner to do so, or to release ownership so another loving packager can take it on.
Comment 7 Matt Domsch 2008-09-18 13:35:40 EDT
Closing this one, now that I cloned the upgrade for to 0.1.7 into it's own RFE bug.

Note You need to log in before you can comment on or make changes to this bug.